summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorOlivier Thauvin <nanardon@mandriva.org>2005-10-09 16:57:07 +0000
committerOlivier Thauvin <nanardon@mandriva.org>2005-10-09 16:57:07 +0000
commitee97c846827eb2c6f18b4e7a15994673136b2470 (patch)
tree22b1331f8d19fe28821d59779be1341e93f7d226 /Makefile.PL
parentc6805f46921be979f492c935505a3e7658f689a7 (diff)
downloadperl-MDV-Distribconf-ee97c846827eb2c6f18b4e7a15994673136b2470.tar
perl-MDV-Distribconf-ee97c846827eb2c6f18b4e7a15994673136b2470.tar.gz
perl-MDV-Distribconf-ee97c846827eb2c6f18b4e7a15994673136b2470.tar.bz2
perl-MDV-Distribconf-ee97c846827eb2c6f18b4e7a15994673136b2470.tar.xz
perl-MDV-Distribconf-ee97c846827eb2c6f18b4e7a15994673136b2470.zip
- add MANIFEST, Makefile.PL
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..d99b018
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,21 @@
+# $Id$
+
+# use 5.008;
+use ExtUtils::MakeMaker;
+use Getopt::Long;
+
+sub MY::postamble {
+ <<MAKECHANGELOG;
+.PHONY: ChangeLog
+
+ChangeLog:
+ cvs2cl -W 400 -I ChangeLog --accum -U ../common/username
+ rm -f *.bak
+
+MAKECHANGELOG
+}
+
+WriteMakefile(
+ NAME => 'MDV::Distribconf',
+ VERSION_FROM => 'lib/MDV/Distribconf.pm',
+);