aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..dce9375
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,20 @@
+# Copyrigt 2012 Kamil Rytarowski <kamil AT mageia DOT org>
+#
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+cmake_minimum_required (VERSION 2.8)
+project (mgasvnstats)
+
+add_executable (mgasvnstats main.cpp)
+
+set(CMAKE_MODULE_PATH
+ "${PROJECT_SOURCE_DIR}/cmake/modules")
+
+find_package (PugiXML REQUIRED)
+include_directories (${PUGIXML_INCLUDE_DIR})
+target_link_libraries (mgasvnstats ${PUGIXML_LIBRARY})
+
+set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror") \ No newline at end of file