summaryrefslogtreecommitdiffstats
path: root/perl-install/c/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'perl-install/c/Makefile.PL')
-rw-r--r--perl-install/c/Makefile.PL18
1 files changed, 6 insertions, 12 deletions
diff --git a/perl-install/c/Makefile.PL b/perl-install/c/Makefile.PL
index 0c41585a2..bb7eed0d1 100644
--- a/perl-install/c/Makefile.PL
+++ b/perl-install/c/Makefile.PL
@@ -1,17 +1,11 @@
use ExtUtils::MakeMaker;
# See lib/ExtUtils/MakeMaker.pm for details of how to influence
# the contents of the Makefile that is written.
-
-my $libs = '-L/usr/X11R6/lib -lX11 -lgdk -lXxf86misc';
-$libs .= ' -lrpm -ldb1 -lz' if $ENV{C_RPM};
-
WriteMakefile(
- 'NAME' => 'stuff',
- 'OPTIMIZE' => '-Os',
- 'MAKEFILE' => 'Makefile_c',
- 'OBJECT' => 'stuff.o smp.o md5.o md5_crypt.o sbus.o silo.o',
- 'VERSION_FROM' => 'stuff.pm', # finds $VERSION
- 'LIBS' => [$libs], # e.g., '-lm'
- 'DEFINE' => '-DHIGHFIRST -D"MD5Name(x)=x"', # e.g., '-DHAVE_SOMETHING'
- 'INC' => '-I/usr/include/rpm `gtk-config --cflags`', # e.g., '-I/usr/include/other'
+ 'NAME' => 'c',
+ 'VERSION_FROM' => 'c.pm', # finds $VERSION
+ 'LIBS' => ['-ldb1 -lz'], # e.g., '-lm'
+# 'OBJECT' => 'c.o librpm.a',
+ 'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
+ 'INC' => '-Wall', # e.g., '-I/usr/include/other'
);