summaryrefslogtreecommitdiffstats
path: root/perl-install/Newt/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'perl-install/Newt/Makefile.PL')
-rw-r--r--perl-install/Newt/Makefile.PL13
1 files changed, 13 insertions, 0 deletions
diff --git a/perl-install/Newt/Makefile.PL b/perl-install/Newt/Makefile.PL
new file mode 100644
index 000000000..6378a8f31
--- /dev/null
+++ b/perl-install/Newt/Makefile.PL
@@ -0,0 +1,13 @@
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+
+WriteMakefile(
+ 'NAME' => 'Newt',
+ 'OBJECT' => 'Av_CharPtrPtr.o Newt.o',
+ 'MAKEFILE' => 'Makefile_c',
+ 'OPTIMIZE' => '-Os',
+ 'VERSION_FROM' => 'Newt.pm', # finds $VERSION
+ 'LIBS' => ['-lnewt -lslang'],
+ 'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
+);