summaryrefslogtreecommitdiffstats
path: root/drakpxelinux.spec
diff options
context:
space:
mode:
Diffstat (limited to 'drakpxelinux.spec')
-rw-r--r--drakpxelinux.spec59
1 files changed, 59 insertions, 0 deletions
diff --git a/drakpxelinux.spec b/drakpxelinux.spec
new file mode 100644
index 0000000..610f28a
--- /dev/null
+++ b/drakpxelinux.spec
@@ -0,0 +1,59 @@
+%define version 0.5.0
+%define name drakpxelinux
+%define release 1mdk
+
+Summary: PXE default file configurator
+Name: %{name}
+Version: %{version}
+Release: %{release}
+Source0: %{name}-%{version}.tar.bz2
+License: GPL
+URL: http://people.mandrakesoft.com/~aginies/drakpxe2.jpg
+Group: System/Configuration/Other
+Packager: Antoine Ginies <aginies@mandrakesoft.com>
+Requires: perl-GTK, perl-MDK-Common, pxe, drakxtools
+BuildRoot: %{_tmppath}/%{name}-buildroot
+Buildarch: noarch
+
+%description
+Quick configuration of PXE menu parameters.
+
+%prep
+%setup -q
+
+%build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make prefix=$RPM_BUILD_ROOT install
+
+#menu
+mkdir -p $RPM_BUILD_ROOT%{_menudir}
+cat >$RPM_BUILD_ROOT%{_menudir}/%{name} <<EOF
+?package(%{name}): command="/usr/X11R6/bin/%{name}" section="Office/Accessories" \
+icon="configuration_section.xpm" needs="x11" title="Drakpxelinux" \
+longtitle="Mandrake Pxelinux configurator"
+EOF
+
+#install lang
+%{find_lang} %{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+%{update_menus}
+
+%postun
+%{clean_menus}
+
+%files -f %{name}.lang
+%defattr(-,root,root)
+%doc default TODO COPYING
+%{_prefix}/X11R6/bin/*
+%{_datadir}/%{name}
+%{_menudir}/%{name}
+
+%changelog
+* Thu Jul 22 2004 Antoine Ginies <aginies@mandrakesoft.com> 0.5.0-1mdk
+- first release