aboutsummaryrefslogtreecommitdiffstats
path: root/krootwarning/krootwarning/Makefile.am
diff options
context:
space:
mode:
authorMystery Man <unknown@mandriva.org>2001-08-08 13:49:54 +0000
committerMystery Man <unknown@mandriva.org>2001-08-08 13:49:54 +0000
commit9e461b62fc49e33e98da31faf0478bb5170210f8 (patch)
treecea75f67d41fdfc45b3d081ae26b7f859c71f830 /krootwarning/krootwarning/Makefile.am
parentcc44483872772b790ee62b12056531a83c0ef7fd (diff)
downloadcommon-data-topic/Laurent.tar
common-data-topic/Laurent.tar.gz
common-data-topic/Laurent.tar.bz2
common-data-topic/Laurent.tar.xz
common-data-topic/Laurent.zip
This commit was manufactured by cvs2svn to create branch 'Laurent'.topic/Laurent
Diffstat (limited to 'krootwarning/krootwarning/Makefile.am')
-rw-r--r--krootwarning/krootwarning/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/krootwarning/krootwarning/Makefile.am b/krootwarning/krootwarning/Makefile.am
new file mode 100644
index 0000000..b6d4888
--- /dev/null
+++ b/krootwarning/krootwarning/Makefile.am
@@ -0,0 +1,39 @@
+
+bin_PROGRAMS = krootwarning
+krootwarning_SOURCES = krootwarning.cpp main.cpp
+krootwarning_METASOURCES = AUTO
+krootwarning_LDADD = $(LIB_QT) $(LIB_KDECORE) $(LIB_KDEUI) $(LIBSOCKET)
+
+
+EXTRA_DIST = main.cpp krootwarning.cpp krootwarning.h krootwarning.desktop lo32-app-krootwarning.png lo16-app-krootwarning.png
+
+install-data-local:
+ $(mkinstalldirs) $(kde_appsdir)/Applications/
+ $(INSTALL_DATA) $(srcdir)/krootwarning.desktop $(kde_appsdir)/Applications/krootwarning.desktop
+ $(mkinstalldirs) $(kde_icondir)/locolor/32x32/apps/
+ $(INSTALL_DATA) $(srcdir)/lo32-app-krootwarning.png $(kde_icondir)/locolor/32x32/apps/krootwarning.png
+ $(mkinstalldirs) $(kde_icondir)/locolor/16x16/apps/
+ $(INSTALL_DATA) $(srcdir)/lo16-app-krootwarning.png $(kde_icondir)/locolor/16x16/apps/krootwarning.png
+
+uninstall-local:
+ -rm -f $(kde_appsdir)/Applications/krootwarning.desktop
+ -rm -f $(kde_icondir)/locolor/32x32/apps/krootwarning.png
+ -rm -f $(kde_icondir)/locolor/16x16/apps/krootwarning.png
+
+
+# set the include path for X, qt and KDE
+INCLUDES= $(all_includes)
+
+SUBDIRS = . pics
+
+METASOURCES = AUTO
+
+# the library search path.
+krootwarning_LDFLAGS = $(all_libraries) $(KDE_RPATH)
+
+messages:
+ LIST=`find . -name \*.h -o -name \*.hh -o -name \*.H -o -name \*.hxx -o -name \*.hpp -o -name \*.cpp -o -name \*.cc -o -name \*.cxx -o -name \*.ecpp -o -name \*.C`; \
+ if test -n "$$LIST"; then \
+ $(XGETTEXT) $$LIST -o $(podir)/krootwarning.pot; \
+ fi
+