aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..2ff3507
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+#!/usr/bin/python
+from distutils.core import setup
+import sys
+import re
+
+verpat = re.compile("VERSION *= *\"(.*)\"")
+data = open("repsys").read()
+m = verpat.search(data)
+if not m:
+ sys.exit("error: can't find VERSION")
+VERSION = m.group(1)
+
+setup(name="repsys",
+ version = VERSION,
+ description = "Tools for Mandriva Linux repository access and management",
+ author = "Gustavo Niemeyer",
+ author_email = "gustavo@niemeyer.net",
+ url = "http://qa.mandriva.com/twiki/bin/view/Main/RepositorySystem",
+ license = "GPL",
+ long_description = """Tools for Mandriva Linux repository access and management.""",
+ packages = ["RepSys", "RepSys.cgi", "RepSys.commands"],
+ scripts = ["repsys"]
+ )