aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFrederic Lepied <flepied@mandriva.com>2005-12-07 10:06:33 +0000
committerFrederic Lepied <flepied@mandriva.com>2005-12-07 10:06:33 +0000
commit2c78c40c9bfae22d1501022b2e52cf938b5a957e (patch)
tree33a030236dd735f665e7b1ff1a9fba203742ecc0 /setup.py
parentaa9174bf0cce8d6a3c6e4d9e795be717da184406 (diff)
downloadmgarepo-2c78c40c9bfae22d1501022b2e52cf938b5a957e.tar
mgarepo-2c78c40c9bfae22d1501022b2e52cf938b5a957e.tar.gz
mgarepo-2c78c40c9bfae22d1501022b2e52cf938b5a957e.tar.bz2
mgarepo-2c78c40c9bfae22d1501022b2e52cf938b5a957e.tar.xz
mgarepo-2c78c40c9bfae22d1501022b2e52cf938b5a957e.zip
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..2ff3507
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+#!/usr/bin/python
+from distutils.core import setup
+import sys
+import re
+
+verpat = re.compile("VERSION *= *\"(.*)\"")
+data = open("repsys").read()
+m = verpat.search(data)
+if not m:
+ sys.exit("error: can't find VERSION")
+VERSION = m.group(1)
+
+setup(name="repsys",
+ version = VERSION,
+ description = "Tools for Mandriva Linux repository access and management",
+ author = "Gustavo Niemeyer",
+ author_email = "gustavo@niemeyer.net",
+ url = "http://qa.mandriva.com/twiki/bin/view/Main/RepositorySystem",
+ license = "GPL",
+ long_description = """Tools for Mandriva Linux repository access and management.""",
+ packages = ["RepSys", "RepSys.cgi", "RepSys.commands"],
+ scripts = ["repsys"]
+ )