aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..0170347
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,19 @@
+AC_PREREQ(2.59)
+AC_INIT([youri-submit], [0.10])
+AM_INIT_AUTOMAKE([-Wall -Werror foreign])
+
+AC_PATH_PROG([PERL],[perl])
+if test -z $PERL; then
+ AC_MSG_ERROR([perl not found, aborting])
+fi
+
+AC_PATH_PROG([POD2MAN],[pod2man])
+if test -z $POD2MAN; then
+ AC_MSG_ERROR([pod2man not found, aborting])
+fi
+
+perllibdir=$datadir/youri/lib
+AC_SUBST(perllibdir)
+
+AC_CONFIG_FILES([Makefile bin/Makefile lib/Makefile etc/Makefile t/Makefile])
+AC_OUTPUT