aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..38343c8
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,31 @@
+# $Id: Makefile.PL 1724 2006-10-17 13:55:27Z warly $
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'youri-core',
+ VERSION => 0.9,
+ AUTHOR => 'Youri project <youri@zarb.org>',
+ PREREQ_PM => {
+ 'AppConfig' => 0,
+ 'YAML' => 0,
+ 'Pod::Simple::HTMLBatch' => 0,
+ 'Test::Exception' => 0,
+ 'Exception' => 0,
+ 'RPM4' => 0,
+ 'URPM' => 0
+ }
+);
+
+package MY;
+
+sub top_targets {
+ my ($self) = @_;
+ my $top_targets = $self->SUPER::top_targets(@_);
+ $top_targets =~ s/all :: pure_all manifypods/all :: pure_all manifypods htmlifypods/;
+ $top_targets .= <<'EOF';
+htmlifypods : $(TO_INST_PM)
+ if [ ! -d blib/html ]; then mkdir blib/html; fi
+ perl -MPod::Simple::HTMLBatch -e Pod::Simple::HTMLBatch::go lib blib/html
+EOF
+ return $top_targets;
+}