aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorFlorent Villard <warly@mandriva.com>2006-10-17 13:55:27 +0000
committerFlorent Villard <warly@mandriva.com>2006-10-17 13:55:27 +0000
commit722eee9d03fb1933fed011a215b71b2c7603e442 (patch)
tree45a45361149df904184e4d94003b019406720f49 /Makefile.PL
parent9e9f23d79d3149806c627ed395ce8278ff1ce3f9 (diff)
downloadmga-youri-core-722eee9d03fb1933fed011a215b71b2c7603e442.tar
mga-youri-core-722eee9d03fb1933fed011a215b71b2c7603e442.tar.gz
mga-youri-core-722eee9d03fb1933fed011a215b71b2c7603e442.tar.bz2
mga-youri-core-722eee9d03fb1933fed011a215b71b2c7603e442.tar.xz
mga-youri-core-722eee9d03fb1933fed011a215b71b2c7603e442.zip
merge with upstream
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL58
1 files changed, 6 insertions, 52 deletions
diff --git a/Makefile.PL b/Makefile.PL
index a8666ea..7204f9b 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -2,32 +2,22 @@
use ExtUtils::MakeMaker;
WriteMakefile(
- NAME => 'youri',
+ NAME => 'youri-core',
VERSION => 0.9,
AUTHOR => 'Youri project <youri@zarb.org>',
- EXE_FILES => [ 'bin/youri-check', 'bin/youri-upload' ],
PREREQ_PM => {
'AppConfig' => 0,
'YAML' => 0,
- 'DateTime' => 0,
- 'Pod::Simple::HTMLBatch' => 0
+ 'Pod::Simple::HTMLBatch' => 0,
+ 'Test::Exception' => 0,
+ 'Exception' => 0,
+ 'RPM4' => 0,
+ 'URPM' => 0
}
);
package MY;
-sub post_constants {
- my ($self) = @_;
- my $sysconfdir =
- $self->{ARGS}->{SYSCONFDIR} ||
- ($self->{INSTALLDIRS} eq 'site' ?
- '/usr/local/etc' :
- '/usr/etc');
- return <<EOF;
-SYSCONFDIR = $sysconfdir
-EOF
-}
-
sub top_targets {
my ($self) = @_;
my $top_targets = $self->SUPER::top_targets(@_);
@@ -36,42 +26,6 @@ sub top_targets {
htmlifypods : $(TO_INST_PM)
if [ ! -d blib/html ]; then mkdir blib/html; fi
perl -MPod::Simple::HTMLBatch -e Pod::Simple::HTMLBatch::go lib blib/html
- -perl -MPod::Simple::HTML -e Pod::Simple::HTML::go bin/youri-check blib/html/youri-check.html
- -perl -MPod::Simple::HTML -e Pod::Simple::HTML::go bin/youri-upload blib/html/youri-upload.html
EOF
return $top_targets;
}
-
-sub install {
- my ($self) = @_;
- my $install = $self->SUPER::install(@_);
- $install =~ s/install :: all pure_install doc_install/install :: all pure_install doc_install config_install completion_install/;
- $install .= <<'EOF';
-config_install :
- install -d -m 755 $(DESTDIR)$(SYSCONFDIR)/youri
- install -m 644 etc/check.conf $(DESTDIR)$(SYSCONFDIR)/youri
- install -m 644 etc/upload.conf $(DESTDIR)$(SYSCONFDIR)/youri
-
-completion_install :
- install -d -m 755 $(DESTDIR)$(SYSCONFDIR)/bash_completion.d
- install -m 644 etc/bash_completion.d/youri $(DESTDIR)$(SYSCONFDIR)/bash_completion.d
-EOF
- return $install;
-}
-
-sub installbin {
- my ($self) = @_;
- my $installbin = $self->SUPER::installbin(@_);
- $installbin .= <<'EOF';
-bin/youri-check : bin/youri-check.in Makefile
- perl -p \
- -e 's|\@sysconfdir\@|$(SYSCONFDIR)|;' \
- < $< > $@
-
-bin/youri-upload : bin/youri-upload.in Makefile
- perl -p \
- -e 's|\@sysconfdir\@|$(SYSCONFDIR)|;' \
- < $< > $@
-EOF
- return $installbin;
-}