summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 161e8a4..1a8319b 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,7 @@
#!/usr/bin/python
from distutils.core import setup
import re
+import os
verpat = re.compile("VERSION *= *\"(.*)\"")
data = open("bm").read()
@@ -9,6 +10,9 @@ if not m:
sys.exit("error: can't find VERSION")
VERSION = m.group(1)
+bash_dir = "/etc/bash_completion.d"
+man_dir = "share/man"
+
setup(name="bm",
version = VERSION,
description = "BuildManager - rpm package building helper",
@@ -24,6 +28,10 @@ controling logs, rpm and srpm moving, filtering the list of files, ignoring
given packages, completely cleaning the build directories, and many other
features.
""",
+ data_files=[
+ (bash_dir, ["bash-completion/bm"]),
+ (os.path.join(man_dir, "man8"), ["man/bm.8"]),
+ ],
packages = ["BuildManager"],
scripts = ["bm", "bmclean"],
)