aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorChristian Belisle <cbelisle@mandriva.com>2002-01-15 15:18:25 +0000
committerChristian Belisle <cbelisle@mandriva.com>2002-01-15 15:18:25 +0000
commit48834357baee4d655bc4698cd49e3dd51f230e44 (patch)
tree400312fcf9ebdef6ee729b66c7610ddda99257a0 /configure.in
parent51f0db8588d837fe50778a15f5dd24260fea0345 (diff)
downloadtransfugdrake-48834357baee4d655bc4698cd49e3dd51f230e44.tar
transfugdrake-48834357baee4d655bc4698cd49e3dd51f230e44.tar.gz
transfugdrake-48834357baee4d655bc4698cd49e3dd51f230e44.tar.bz2
transfugdrake-48834357baee4d655bc4698cd49e3dd51f230e44.tar.xz
transfugdrake-48834357baee4d655bc4698cd49e3dd51f230e44.zip
removed
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in68
1 files changed, 0 insertions, 68 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index 5b5e72e..0000000
--- a/configure.in
+++ /dev/null
@@ -1,68 +0,0 @@
-dnl Autoconfigure input file for hexedit
-dnl
-dnl Process this file with autoconf to produce a configure script.
-dnl
-
-AC_INIT(transfugdrake.c)
-dnl AC_CONFIG_HEADERS(config.h)
-
-define(TheVERSION, 0.1)
-
-PRODUCT=transfugdrake
-VERSION=TheVERSION
-INCL=hexedit.h
-SRCS="transfudrake.c"
-OTHER="COPYING AUTHORS README TODO configure config.h.in Makefile.in configure.in Makefile-build.in transfugdrake"
-AC_SUBST(PRODUCT)
-AC_SUBST(VERSION)
-AC_SUBST(INCL)
-AC_SUBST(SRCS)
-AC_SUBST(OTHER)
-
-dnl Enable GNU extensions on systems that have them.
-AH_VERBATIM([_GNU_SOURCE],
-[/* Enable GNU extensions on systems that have them. */
-#ifndef _GNU_SOURCE
-# define _GNU_SOURCE
-#endif])
-AC_DEFINE(_GNU_SOURCE)
-
-dnl Checks for programs.
-AC_PROG_CC
-AC_PROG_INSTALL
-
-dnl Checks for libraries.
-dnl AC_CHECK_LIB(curses, initscr, LIBS="$LIBS -lcurses",
-dnl AC_CHECK_LIB(ncurses, initscr, LIBS="$LIBS -lncurses"))
-
-dnl This test must come as early as possible after the compiler configuration
-dnl tests, because the choice of the file model can (in principle) affect
-dnl whether functions and headers are available, whether they work, etc.
-dnl AC_SYS_LARGEFILE
-
-dnl Checks for header files.
-AC_HEADER_STDC
-AC_HEADER_STAT
-AC_HEADER_SYS_WAIT
-dnl AC_CHECK_HEADERS(fcntl.h unistd.h libgen.h)
-
-dnl Checks for typedefs, structures, and compiler characteristics.
-AC_C_CONST
-AC_TYPE_SIZE_T
-
-dnl Checks for library functions.
-AC_CHECK_FUNCS(memcmp memmem memrmem memrchr strdup strerror basename)
-if test $ac_cv_func_basename = no; then
- # basename not in the default libraries. See if it's elsewhere
- AC_CHECK_LIB(gen, basename, [AC_DEFINE(HAVE_BASENAME)
- LIBS="$LIBS -lgen"])
-fi
-
-dnl AC_CHECK_DECLS([dirname, basename, memrchr, memmem, memrmem], , ,
-dnl $ac_includes_default
-dnl #if HAVE_LIBGEN_H
-dnl #include <libgen.h>
-dnl #endif
-dnl )
-
-AC_OUTPUT(Makefile Makefile-build)