summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 4b8f53e7..988bdb56 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -162,10 +162,10 @@ WriteMakefile(
map {
my $targ = $_;
$targ =~ s{^pod/}{};
- $targ =~ s/\.(\d)\.pod$//;
+ $targ =~ s{^(\d)/(.*)\.pod$}{$2};
my $section = $1 || 1;
( $_ => "\$(INST_MAN${section}DIR)/$targ.$section" );
- } <pod/*.pod>, $with_po ? <pod/*/*.pod> : ()
+ } <pod/*/*.pod>, $with_po ? <pod/*/*.pod> : ()
},
dist => { COMPRESS => "xz -f", SUFFIX => ".xz" },
);