summaryrefslogtreecommitdiffstats
path: root/t/SPECS/various.spec
diff options
context:
space:
mode:
authorPascal Rigaux <pixel@mandriva.com>2006-11-30 13:28:03 +0000
committerPascal Rigaux <pixel@mandriva.com>2006-11-30 13:28:03 +0000
commit37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe (patch)
tree9847ca49d51ce41e951fcabcd0ed6344a3e5009a /t/SPECS/various.spec
parente15d45cca3d34d223927cf37f497de3a9703fb78 (diff)
downloadurpmi-37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe.tar
urpmi-37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe.tar.gz
urpmi-37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe.tar.bz2
urpmi-37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe.tar.xz
urpmi-37b66b6b34d29c9e628c4a0bbf5babdb5e1340fe.zip
using --urpmi-root, create some tests using urpmi.addmedia, urpmi, urpme
one drawback of the superuser--*.t is the need to be root (the rpmlib needs it to install in a root partition), so for now "make test" tests *.t but superuser--*.t are skipped. Then as root, run "sudo make test TEST_FILES='t/superuser--*.t'"
Diffstat (limited to 't/SPECS/various.spec')
-rw-r--r--t/SPECS/various.spec38
1 files changed, 38 insertions, 0 deletions
diff --git a/t/SPECS/various.spec b/t/SPECS/various.spec
new file mode 100644
index 00000000..b7d62e8f
--- /dev/null
+++ b/t/SPECS/various.spec
@@ -0,0 +1,38 @@
+Summary: various
+Name: various
+Version: 1
+Release: 1
+License: x
+Group: x
+Url: x
+BuildRoot: %{_tmppath}/%{name}
+
+%prep
+echo foo > foo
+
+%build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+for i in /etc/test-%{name} \
+ /var/lib/test-%{name}/foo1 /var/lib/test-%{name}/foo2 /var/lib/test-%{name}/foo3 \
+ /usr/share/locale/fr/LC_MESSAGES/test-%{name}.mo \
+ /usr/test-%{name}/foo; do
+ install -d `dirname $RPM_BUILD_ROOT$i`
+ echo foo > $RPM_BUILD_ROOT$i
+done
+
+%find_lang test-%{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%description
+x
+
+%files -f test-%{name}.lang
+%defattr(-,root,root)
+%doc foo
+%config(noreplace) /etc/*
+/var/lib/*
+/usr/test-%{name}