aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL18
1 files changed, 2 insertions, 16 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 056e597..be823d4 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -3,17 +3,7 @@
use strict;
use ExtUtils::MakeMaker;
-my $rpmtools_version = "5.1.0";
-
-# to generate the ChangeLog depending on the checkout layout
-my $commonusername = "../common/";
--d $commonusername or do {
- $commonusername = "../../common/";
- -d $commonusername or do {
- $commonusername = "../../../common/";
- -d $commonusername or $commonusername = "";
- };
-};
+my $rpmtools_version = "5.2.0";
sub MY::postamble {
<<MAKEMAKEFILE;
@@ -32,7 +22,7 @@ cleanc:
rm -rf *.cz test
ChangeLog:
- LC_ALL=C svn2cl --accum --strip-prefix=soft/rpm/rpmtools/trunk --authors ${commonusername}username.xml
+ LC_ALL=C svn2cl --accum --strip-prefix=soft/rpm/rpmtools/trunk
rm -f *.bak
MAKEMAKEFILE
@@ -53,11 +43,7 @@ WriteMakefile(
pm_to_blib => 'buildc',
},
PM => {
- 'Packdrakeng.pm' => '$(INST_LIBDIR)/Packdrakeng.pm',
- 'Packdrakeng/zlib.pm' => '$(INST_LIBDIR)/Packdrakeng/zlib.pm',
'packdrake.pm' => '$(INST_LIBDIR)/packdrake.pm',
- 'Distribconf.pm' => '$(INST_LIBDIR)/Distribconf.pm',
- 'Distribconf/Build.pm' => '$(INST_LIBDIR)/Distribconf/Build.pm',
},
EXE_FILES => [ qw(gendistrib genhdlist packdrake rpm2header parsehdlist rpm2cpio.pl dumpdistribconf) ],
C => [],