summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* move: Fix sanity check display.user/colin/improvementsColin Guthrie2014-07-291-8/+8
| | | | | Also some cosmetic changes and fixes for the handling of the sanity check response.
* Properly scope local variables.Colin Guthrie2014-07-291-10/+11
| | | | | | | | This is needed specifically in the case of update_hdlist() where a previous run would set the ofdeps variable which would then be reused on the next run. This is typically not a big problem but it did mean that standard media file-deps file was used when updating debug media which seems incorrect.
* Fix argument count checkColin Guthrie2014-07-291-1/+1
|
* Move the --dry-run handling into the functions file.Colin Guthrie2014-07-296-25/+7
|
* Support running the scripts from a direct git clone.Colin Guthrie2014-07-296-6/+31
|
* move: Rename mga-move-update to mga-move-pkgColin Guthrie2014-07-292-1/+2
| | | | | | | The -update suffix was no longer relevant since support for other subsections than 'updates' was added. Also install it :)
* move: Switch to non-sync by default.Colin Guthrie2014-07-291-6/+6
| | | | All the scripts on the build server behaved this way so we may as well too.
* move: Add support for moving backport packages.Colin Guthrie2014-07-291-17/+45
| | | | | | | | | | | | | | | This replaces two scripts found on the build system: mga-move-backports-{nosync,sync-mail} The latter scripts name includes the word 'sync' but it didn't actually do the sync. but as this script supports a --no-sync option, this is now fully optional. There seemed to be a stray $ in the old file. I don't think it was deliberate. The mail sent to the backports ML is nicer than before as it doesn't include output from raw commands, just a human readable equiv. This also still sends a mail for audit purposes regardless of the nice announce email
* move: Add support for moving packages from cauldron update_testing to release.Colin Guthrie2014-07-291-12/+60
| | | | Most of the code is the same/shared so it makes sense to do this in one script
* move: Spruce up the mga-move-update script.Colin Guthrie2014-07-291-58/+91
| | | | | | | | | | | | | This tidies up the script and modernises it. It adds various options that allow more practical usage. This includes a specific --dry-run option to just test things and a --no-sync option which allows the usage we expect when processing updates (the sync process takes a long time and thus it's better to leave it until several updates are processed). It also adds support for a slightly nicer email notification and adds an option (--no-confirm) to avoid the confirmation step if you pass an exact srpm name into the script rather than just the %{name} part of it which will be useful when this process is automated.
* move: Fix permsColin Guthrie2014-07-291-0/+0
|
* functions: Fix dryrun support for updating of hdlists.Colin Guthrie2014-07-291-6/+6
|
* Add some utility scripts to update hdlists.Colin Guthrie2014-07-296-0/+135
| | | | | | | | These are the same scripts that were present on the live server and have thus proven useful. That said, common code has been factored out and centralised and the syntax has been neatened up.
* functions: Move default values into the main include file.Colin Guthrie2014-07-282-16/+26
| | | | | This keeps the config file but ensures it's not 100% needed via default values
* function: Fix shell script styleColin Guthrie2014-07-281-18/+9
|
* Typo fixSandro Cazzaniga2012-09-251-1/+1
|
* revert previous commitSandro Cazzaniga2012-09-251-51/+36
|
* tidying the codeSandro Cazzaniga2012-09-251-36/+51
|
* further simplify (Pascal Terjan)Thierry Vignaud2012-03-161-1/+1
|
* make clean-rpmsrate 11.5% faster on average on cached repo directory byThierry Vignaud2012-03-152-1/+5
| | | | | | | doing less work in the regexp engine and less path walks elapsed time consistently go down from 0.70 to 0.62 on scores of run (mainly a win in time spend in the kernel)
* rename $d as $dir for clarityThierry Vignaud2012-03-151-2/+2
|
* reorder for clarityThierry Vignaud2012-03-151-1/+2
|
* rename $rpmsrate_base as $rpmsrate_raw_fileThierry Vignaud2012-03-151-2/+2
|
* make it slight clearerThierry Vignaud2012-03-151-1/+1
|
* only cleanrpmsrate() is exported and we don't call anything else anywayThierry Vignaud2012-03-151-1/+1
|
* (cleanrpmsrate) the only caller of this function doesn't care about what we ↵Thierry Vignaud2012-03-151-2/+0
| | | | collected so don't return anything...
* (check_if_expandable) one less argumentThierry Vignaud2012-03-151-4/+3
|
* (cleanrpmsrate) kill code commented out for 8 yearsThierry Vignaud2012-03-151-1/+0
|
* (cleanrpmsrate) free URPM object once unusedThierry Vignaud2012-03-151-0/+1
|
* log previous changesThierry Vignaud2012-03-151-0/+6
|
* (check_if_expandable) fix matching locales-xx_XX for localized packagesThierry Vignaud2012-03-152-1/+3
| | | | (eg: would be needed for gcompris-sound-zh*)
* (lookup_pkg,check_if_expandable,cleanrpmsrate) simplify: kill unused $o_urpm ↵Thierry Vignaud2012-03-151-12/+8
| | | | parameter (no overengeneering)
* (preread_rpmsrate,cleanrpmsrate) simplify: kill unused $norpmsrate parameter ↵Thierry Vignaud2012-03-152-10/+6
| | | | (no overengeneering)
* (cleanrpmsrate) add a commentThierry Vignaud2012-03-151-0/+1
|
* (cleanrpmsrate) fix matching dkms (broken for years...)Thierry Vignaud2012-03-151-1/+1
|
* (cleanrpmsrate) looks for mga extension, not mdv (broken since mga fork)Thierry Vignaud2012-03-151-2/+2
|
* (lookup_pkg) split it out of check_if_expandable()Thierry Vignaud2012-03-151-9/+12
|
* (cleanrpmsrate) rename a variable for better readingThierry Vignaud2012-03-151-2/+2
|
* (cleanrpmsrate) rename a variable for better readingThierry Vignaud2012-03-151-4/+4
|
* (cleanrpmsrate) simplifyThierry Vignaud2012-03-151-5/+3
|
* (cleanrpmsrate) rename a variable for better readingThierry Vignaud2012-03-151-6/+6
|
* (cleanrpmsrate) reduce scope of some variablesThierry Vignaud2012-03-151-1/+3
|
* (cleanrpmsrate) factorize a testThierry Vignaud2012-03-151-3/+6
|
* (cleanrpmsrate) try to make an over complicated if() more readableThierry Vignaud2012-03-151-7/+12
|
* (cleanrpmsrate) simplifyThierry Vignaud2012-03-151-2/+1
|
* (check_if_expandable) split it out of cleanrpmsrate()Thierry Vignaud2012-03-151-25/+32
|
* add commentsThierry Vignaud2012-03-151-0/+3
|
* rename $rpmsrate as $output_file to show its real purposeThierry Vignaud2012-03-151-3/+3
|
* no need to blacklist URPM anymoreThierry Vignaud2012-03-151-1/+0
|
* (cleanrpmsrate) $urpm argument is not mandatory and is not actuallyThierry Vignaud2012-03-151-2/+2
| | | | passsed by clean-rpmsrate