aboutsummaryrefslogtreecommitdiffstats
path: root/initscripts.spec
diff options
context:
space:
mode:
authorBill Nottingham <notting@redhat.com>2002-07-15 20:52:51 +0000
committerBill Nottingham <notting@redhat.com>2002-07-15 20:52:51 +0000
commite4b06c611eabeb101edfdbd63924f390b2462682 (patch)
treee45ef84694c923c2f4facf9bef41bd1570e18e95 /initscripts.spec
parenta41e71270e820c07ee11aa332c7ee8555b314bc8 (diff)
downloadinitscripts-e4b06c611eabeb101edfdbd63924f390b2462682.tar
initscripts-e4b06c611eabeb101edfdbd63924f390b2462682.tar.gz
initscripts-e4b06c611eabeb101edfdbd63924f390b2462682.tar.bz2
initscripts-e4b06c611eabeb101edfdbd63924f390b2462682.tar.xz
initscripts-e4b06c611eabeb101edfdbd63924f390b2462682.zip
6.86-1r6-86
Diffstat (limited to 'initscripts.spec')
-rw-r--r--initscripts.spec6
1 files changed, 5 insertions, 1 deletions
diff --git a/initscripts.spec b/initscripts.spec
index a754602f..1644374a 100644
--- a/initscripts.spec
+++ b/initscripts.spec
@@ -1,6 +1,6 @@
Summary: The inittab file and the /etc/init.d scripts.
Name: initscripts
-Version: 6.85
+Version: 6.86
License: GPL
Group: System Environment/Base
Release: 1
@@ -244,6 +244,10 @@ rm -rf $RPM_BUILD_ROOT
%dir /etc/locale/*/LC_MESSAGES
%changelog
+* Mon Jul 15 2002 Bill Nottingham <notting@redhat.com>
+- fix boot-time cleanup of /var
+- update po files
+
* Thu Jul 11 2002 Florian La Roche <Florian.LaRoche@redhat.de>
- /etc/init.d/functions:
daemon(): avoid starting another bash
class="hl opt">{URPMI_MPUT_COMMAND}; our $rshp_command = $ENV{URPMI_RSHP_COMMAND}; if (!$mput_command) { ($mput_command) = grep { -x $_ } qw(/usr/bin/mput2 /usr/bin/mput); } $mput_command ||= 'mput'; if (!$rshp_command) { ($rshp_command) = grep { -x $_ } qw(/usr/bin/rshp2 /usr/bin/rshp); } $rshp_command ||= 'rshp'; sub _rshp_urpm { my ($parallel, $urpm, $rshp_option, $cmd, $para) = @_; # it doesn't matter for urpmq, and previous version of urpmq didn't handle it: $cmd ne 'urpmq' and $para = "--no-locales $para"; my $command = "$rshp_command $rshp_option $parallel->{options} -- $cmd $para"; $urpm->{log}("parallel_ka_run: $command"); $command; } sub _rshp_urpm_popen { my ($parallel, $urpm, $cmd, $para) = @_; my $command = _rshp_urpm($parallel, $urpm, '-v', $cmd, $para); open(my $fh, "$command |") or $urpm->{fatal}(1, "Can't fork $rshp_command: $!"); $fh; } sub urpm_popen { my ($parallel, $urpm, $cmd, $para, $do) = @_; my $fh = _rshp_urpm_popen($parallel, $urpm, $cmd, $para); while (my $s = <$fh>) { chomp $s; my ($node, $s_) = _parse_rshp_output($s) or next; $urpm->{debug}("parallel_ka_run: $node: received: $s_") if $urpm->{debug}; $do->($node, $s_) and last; } close $fh or $urpm->{fatal}(1, N("rshp failed, maybe a node is unreacheable")); (); } sub run_urpm_command { my ($parallel, $urpm, $cmd, $para) = @_; system(_rshp_urpm($parallel, $urpm, '', $cmd, $para)) == 0; } sub copy_to_dir { &_run_mput } sub propagate_file { my ($parallel, $urpm, $file) = @_; _run_mput($parallel, $urpm, $file, $file); } sub _run_mput { my ($parallel, $urpm, @para) = @_; my @l = (split(' ', $parallel->{options}), '--', @para); $urpm->{log}("parallel_ka_run: $mput_command " . join(' ', @l)); system $mput_command, @l; $? == 0 || $? == 256 or $urpm->{fatal}(1, N("mput failed, maybe a node is unreacheable")); } sub _parse_rshp_output { my ($s) = @_; #- eg of output of rshp2: <tata2.mandriva.com> [rank:2]:@removing@mpich-1.2.5.2-10mlcs4.x86_64 if ($s =~ /<([^>]*)>.*:->:(.*)/ || $s =~ /<([^>]*)>\s*\[[^]]*\]:(.*)/) { ($1, $2); } else { warn "bad rshp output $s\n"; (); } } #- allow to bootstrap from urpmi code directly (namespace is urpm). package urpm; no warnings 'redefine'; sub handle_parallel_options { my (undef, $options) = @_; my ($media, $ka_run_options) = $options =~ /ka-run(?:\(([^\)]*)\))?:(.*)/; if ($ka_run_options) { my ($flush_nodes, %nodes); foreach (split ' ', $ka_run_options) { if ($_ eq '-m') { $flush_nodes = 1; } else { $flush_nodes and $nodes{/host=([^,]*)/ ? $1 : $_} = undef; undef $flush_nodes; } } return bless { media => $media, options => $ka_run_options, nodes => \%nodes, }, "urpm::parallel_ka_run"; } return undef; } 1;