summaryrefslogtreecommitdiffstats
path: root/perl-install/partition_table.pm
Commit message (Collapse)AuthorAgeFilesLines
...
* rename partition_table::raw::clear() into partition_table::initialize()Pascal Rigaux2007-09-181-0/+23
|
* handle "LVM on full disk" like other partition tablesPascal Rigaux2007-09-181-1/+2
|
* drop unused variablesPascal Rigaux2007-09-181-1/+0
|
* create partition_table::raw::read_primary out of partition_table::read_primary()Pascal Rigaux2007-09-181-10/+6
|
* move more things from read() to read_primary()Pascal Rigaux2007-09-181-7/+8
|
* simplify: read_one was used for primary and extended. replacing most of ↵Pascal Rigaux2007-09-181-12/+9
| | | | read_one() with read_primary()
* create pt_info_to_primary() out of partition_table::read_one()Pascal Rigaux2007-09-181-8/+1
|
* rename ->read to ->read_onePascal Rigaux2007-09-181-2/+2
|
* use ->last_usable_sector instead of {totalsectors} so that resizing aPascal Rigaux2007-04-301-1/+1
| | | | | | partition doesn't propose a partition size bigger than what creating a partition propose (#21709)
* re-sync after the big svn lossPascal Rigaux2007-04-251-11/+10
|
* try to cleanup fs.pmPascal Rigaux2005-06-281-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | (to have simpler dependencies between modules, esp. have some modules only required by diskdrake): - move some functions from fs to fs::mount (most keep their name, except mount_part and mount_usbfs) - move formatMount_part and formatMount_all from fs to fs::format - move some functions from fs to fs::wild_device (part2wild_device_name -> fs::wild_device::from_part) (subpart_from_wild_device_name -> fs::wild_device::to_subpart) (analyze_wild_device_name -> fs::wild_device::analyse) - formatMount_part(), formatMount_all(), fs::mount::part() don't take a prefix anymore the current situation was quite muddy we now rely on fs::get::mntpoint_prefixed() which will maybe depend on a field in $part for now, we mount every part in chroot, it seems to be what's wanted - fs::format::part() now expect $all_hds instead of $raids - fs::type::carryRootLoopback is now fs::get::carry_root_loopback() - in fs::loopback, most functions don't want a prefix anymore
* remove unused isPrimaryPascal Rigaux2005-06-031-6/+0
|
* media_browser returns a filehandle when non savePascal Rigaux2005-02-181-1/+6
|
* cleanupPascal Rigaux2005-02-031-1/+1
|
* nicer description() (esp. when the size is 0)Pascal Rigaux2005-01-261-4/+4
|
* better english (writing style rather than spoken one)Thierry Vignaud2004-12-131-5/+5
|
* remove some unneeded ";", add some for normalization (as told by perl_checker)Pascal Rigaux2004-11-181-1/+1
|
* also remove "require partition_table::lvm_PV" comment for perl_checkerPascal Rigaux2004-11-171-1/+0
|
* handle more nicely raw_lvm_PV (don't simply ignore them)Pascal Rigaux2004-11-161-1/+1
|
* don't die in will_tell_kernel() when the device is weird, since it is normal ↵Pascal Rigaux2004-11-161-3/+8
| | | | when destroying a raw_lvm_PV
* enhance readabilityPascal Rigaux2004-11-161-8/+8
|
* create isEmpty() and use it instead of simply testing {pt_type}, since ↵Pascal Rigaux2004-11-161-3/+3
| | | | {pt_type} can be undef whereas {fs_type} is set
* don't use devices::part_number(), otherwise it fails with c0d0p* devicesPascal Rigaux2004-10-051-1/+1
|
* better loggingPascal Rigaux2004-09-221-2/+2
|
* - add field {part_number} for partitionsPascal Rigaux2004-09-201-7/+13
| | | | | | | | | | | (handle it in subpart_from_wild_device_name(), partition_table::read()) - create migrate_device_names() to handle the change of device names when changing kernel&modules (eg: hde->hda or hda->sda) - change prototype of install_any::use_root_part() (prefix is dropped, optional $in is added) - create fs::type::can_be_this_fs_type() and use it - create devices::part_number() and devices::part_prefix() and use them
* - ensure {is_removable} field is there for created partitions, not only ↵Pascal Rigaux2004-09-141-4/+15
| | | | | | | existing partitions - it breaks Create(), fixing
* many functions in fsedit don't modify anything, they are simply accessors.Pascal Rigaux2004-08-031-1/+0
| | | | | | | | | | | | | | | | | | | | | | | | create fs::get and move them into it - device2part(), up_mount_point() moved from fs to fs::get - part2hd(), file2part(), has_mntpoint(), mntpoint2part(), empty_all_hds() moved from fsedit to fs::get - fsedit::get_root() -> fs::get::root() - fsedit::get_root_() -> fs::get::root_() - fsedit::get_really_all_fstab() -> fs::get::really_all_fstab() - fsedit::get_all_fstab_and_holes() -> fs::get::fstab_and_holes() - fsedit::get_all_fstab() -> fs::get::fstab() - fsedit::get_all_holes() -> fs::get::holes() - fsedit::all_free_space -> fs::get::free_space() - fsedit::get_really_all_fstab() -> fs::get::really_all_fstab() - fsedit::get_fstab_and_holes() -> fs::get::hds_fstab_and_holes() - fsedit::get_holes() -> fs::get::hds_holes() - fsedit::get_fstab() -> fs::get::hds_fstab() - fsedit::free_space() -> fs::get::hds_free_space() - fsedit::get_visible_fstab() unused, removed
* - add field {fs_type} partially replacing {pt_type}Pascal Rigaux2004-07-271-269/+10
| | | | | | | | | | | | | | | | | | | | {pt_type} is always a number, {fs_type} is always a string - introduce set_isFormatted() (to ensure {notFormatted} but also {fs_type_from_magic} and {bad_fs_type_magic} are updated) - don't use 0x483 for ext3 anymore (same for reiserfs...), the type_name gives both a pt_type and a fs_type - many accessors from partition_table removed (type2fs(), fs2pt_type()) - remove isThisFs() (not useful anymore since we can use directly {fs_type}) - remove isFat() (inline the function) - other isXXX() from partition_table are moved to fs::type - part2name() is now fs::type::part2type_name - name2pt_type() is now fs::type::type_name2subpart() - partition_table::important_types() is now fs::type::type_names() - fsedit::typeOfPart() is now fs::type::fs_type_from_magic() - no need to truncate type_name since they are shorter
* replace pt_type2name($part->{pt_type}) with part2name($part)Pascal Rigaux2004-07-231-3/+6
| | | | | (hoisting the dereferencing {pt_type})
* - simplify partition table entry names (based on fdisk's names)Pascal Rigaux2004-07-231-113/+100
| | | | | - rename some internal variables
* old dos is not useful anymorePascal Rigaux2004-07-231-1/+1
|
* simplifyPascal Rigaux2004-07-231-5/+6
|
* big renaming of field {type} to {pt_type},Pascal Rigaux2004-07-051-33/+34
| | | | | | this will allow defining {fs_type} which will always be a string whereas {pt_type} will always be a number
* new function isTrueLocalFS() to make a distinction between ext3/reiserfs/... ↵Pascal Rigaux2004-05-271-3/+4
| | | | | | | and nfs => allow /home on nfs (bugzilla #7460)
* perl now handle cleanly utf8 string in exceptions, no need to die \N("...")Pascal Rigaux2004-04-051-5/+5
|
* add set_best_geometry_for_the_partition_table to use the hd geometry instead ↵Pascal Rigaux2004-03-171-0/+2
| | | | of the physical geometry returned by the kernel (since for now i can't have bios geometry on 2.6)
* type 0x17 *can* be ntfs, assuming it is when we don't care much, and check ↵Pascal Rigaux2004-02-181-2/+2
| | | | if it is ntfs otherwise
* - tell kernel to remove the extended partitionPascal Rigaux2004-01-301-1/+2
| | | | | - true/false is better than yes/no in log message
* enhance log message "tell kernel ..."Pascal Rigaux2004-01-301-1/+1
|
* - remove the use of BLKRRPART (telling the kernel to re-read the partition ↵Pascal Rigaux2004-01-151-29/+78
| | | | | | | | | table) in most cases - replace with tell_kernel() and will_tell_kernel() - correctly handle in standalone the need to reboot, with no way to forget it (telling the WM to quit nicely then call reboot when it's done)
* perl_checker compliancePascal Rigaux2004-01-061-2/+3
|
* ensure that a number is not written as the type in fstabPascal Rigaux2003-09-171-1/+5
|
* associate partition table 0xeb (BeOS) with filesystem befs (part of bug #5523)Pascal Rigaux2003-09-151-0/+1
|
* - fix call to openit()Pascal Rigaux2003-08-211-6/+4
| | | | | - replace *F with $F
* - Merge in AMD64 treeGwenolé Beauchesne2003-08-191-2/+8
| | | | | - Handle EFI partitions on IA-64
* perl_checker fixesThierry Vignaud2003-05-231-1/+1
|
* perl_checker adaptations + fixesPascal Rigaux2003-04-241-1/+1
|
* new perl_checker compliancePascal Rigaux2003-04-171-9/+9
|
* set {device_windobe} for 0x107 *and* 0x7 (since 0x107 is not set correctly ↵Pascal Rigaux2003-02-201-2/+6
| | | | | | | at this stage) (otherwise this causes mount points /mnt/win_ /mnt/win_1...)
* to workaround perl bug removing UTF8 flag when passing scalars to die's, passGuillaume Cottenceau2003-02-191-5/+5
| | | | | | a scalar-ref. but we need to de-ref, so it might break many things :). let's make a prayer :).