summaryrefslogtreecommitdiffstats
path: root/perl-install/security
Commit message (Collapse)AuthorAgeFilesLines
...
* remove unused variables or rename them with an underscore (eg: $o becomes $_o)Pascal Rigaux2002-12-041-2/+2
|
* syntax changes to make perl_checker happyPascal Rigaux2002-12-041-1/+1
|
* syntax changes to make perl_checker happyPascal Rigaux2002-12-041-1/+1
|
* share common optionsMystery Man 5802002-12-041-5/+7
|
* - fix obvious pixel typo (s/if/if_/)Mystery Man 5802002-12-041-61/+7
| | | | | | | - no need to maintain dummy documentation about something which is called only in one place - simplify
* fix typoPascal Rigaux2002-12-031-1/+1
|
* simplify (esp. use cat_)Pascal Rigaux2002-12-031-20/+2
|
* (get_value): cleanupPascal Rigaux2002-12-031-34/+20
|
* - gtk2 portThierry Vignaud2002-12-021-46/+48
| | | | | - perl_checker fixes
* simplifyThierry Vignaud2002-11-201-1/+1
|
* cleanupsThierry Vignaud2002-11-201-3/+2
|
* - fix duplication of sec level setting:Thierry Vignaud2002-11-193-39/+59
| | | | | | | | | | | | | merge any::get_secure_level() with secure::msec::get_secure_level() - move security level functions from secure::msec to secure::level - uses secure::level in install_steps - fix duplication of security level labels - draksec: use same strings in drakx, got nice translations - get_default_checks(): make it more readable
* previous example in perldoc was buggy;Thierry Vignaud2002-11-191-14/+21
| | | | | put one that really works
* update copyright yearsThierry Vignaud2002-11-181-1/+1
|
* - use run_program rather than raw systemThierry Vignaud2002-11-151-16/+26
| | | | | | | | | | - kill useless show_msec_help() - kill commented remanant code of help buttons - add tooltip with default values on combos & entries - log about security administrator changes only when we do some - factorize some code into new_editable_combo() and set_default_tip()
* - kill unused myexit()Thierry Vignaud2002-11-141-4/+2
| | | | | - perl_checker fixes
* - perl_checker fixesThierry Vignaud2002-11-141-17/+19
| | | | | | - clean code - simplify config_function()
* add/remove some spaces to make perl_checker happyPascal Rigaux2002-11-121-1/+1
|
* fix _() -> N() conversionThierry Vignaud2002-11-121-1/+1
|
* - replace ... =~ 'foo' with ... =~ /foo/Pascal Rigaux2002-11-112-3/+3
| | | | | - remove unneeded parentheses for things like ... if (...)
* add or remove spaces where need to please perl_checkerPascal Rigaux2002-11-112-6/+7
|
* - use "foreach" instead of "for" in list contextPascal Rigaux2002-11-111-2/+2
| | | | | - use "for" instead of "foreach" when used a la C
* various small syntax enhancements to please perl_checkerPascal Rigaux2002-11-111-2/+2
|
* replace "_" with "N" and "__" with "N_"Pascal Rigaux2002-11-061-17/+17
| | | | | | | | | | | | | | | | | | | rationale: - currently, we use _("xxx") as a shorthand for gettext("xxx"). It also used to call xgettext with --keyword=_ - alas, function &_ is global and not by package (notice esp. that _ is not exported in common.pm) - this lead to big ugly pb with packages defining their own &_, overriding common.pm's &_ - a fix is to set @::textdomains to add a new domain (the default being "libDrakX") but relying on the global "_" is still dangerous!
* remember to factorize this with rpmdrake's wait messages in my_gtkThierry Vignaud2002-09-241-0/+1
|
* ignore_list is uselessThierry Vignaud2002-09-241-2/+1
|
* remove "bogus periodic check 2" from periodic checks pageThierry Vignaud2002-09-241-2/+1
|
* let simplifyThierry Vignaud2002-09-241-2/+1
|
* s/package draksec::libsafe/package security::libsafe/Thierry Vignaud2002-09-191-1/+1
| | | | | anyway nobody uses that one
* - factorize @sec_levels and %sec_levels for get_default() andThierry Vignaud2002-09-181-9/+7
| | | | | | | | get_seclevel_list() - use them in get_default() - get_value() : don't assume a space between "function_name" and "(parameters)"
* fix wait_message doesn't displayThierry Vignaud2002-09-181-2/+4
|
* remove brackets on function values loadingThierry Vignaud2002-09-181-4/+8
|
* run msec after setting changesThierry Vignaud2002-09-181-1/+5
|
* respect msec syntaxThierry Vignaud2002-09-181-1/+1
|
* "kill quart of draksec code" patch aka make it really working aka "happy fred" :Thierry Vignaud2002-09-182-216/+119
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | - security::msec : o consolidate get_function_value() and get_value into get_value() o really apply changes, aka save them : * config_check() : use substInFile and setVarsInSh * config_function() : use substInFile and append_to_file * kill stupid and bogus config_option() o don't overwrite previous changes, aka reread them : * fix checks and functions current value loading * fix checks and functions default loading - security::main : o simplify ui creation, make it more readable o kill offuscating basic_secadmin_check(), basic_secadmin_entry(), network_generate_page(), system_generate_page() and checks_generate_page() o increase default height because of stupid "add_with_viewport" in ugtk::createScrolledWindow o consolidate network and system functions managment, they're all the same for msec, splitting is only a draksec "feature"; all go in %options_values - draksec : o let standalone module configure standalone mode o security::main already take care of initializing gtk o security::main already take care of exiting o don't play with embedded mode special variables it overall looks better but big cleanups're still possible for mdk9.1
* - security::msec :Thierry Vignaud2002-09-172-19/+17
| | | | | | | | | | | | | | | | | | | | | o config_check: use MDK::Common to set option rather than overwriting config file o remove all stupid prefix that just ofuscate code whereas it's always set to '', $::prefix will be a lot better o s/shift @_/shift/ o kill config_option() o simplify get_default() o get_secure_level() : replace if cascade by an array o set_secure_level() : * replace if cascade by an hash * default to runlevel 3 if undefined o get_functions() : simplify by merging code paths - security::main : o security::libsafe is unneeded o don't pass useless prefix o begin to read default values
* - msec::config_check: use MDK::Common to set option ratherThierry Vignaud2002-09-172-138/+99
| | | | | | | | than overwriting config file - remove all stupid prefix that just ofuscate code whereas it's always set to '', $::prefix will be a lot better
* - security::main: kill duplicated 'use strict'Thierry Vignaud2002-09-172-5/+4
| | | | | | | | | | - no ignore choice for periodic checks - save functions in /etc/security/msec/level.local and not security.conf - "from mseclib import" is useless - fix functions saving (an object method invocation takes class name as argument)
* remove libsafe option (not anymore used by msec)Thierry Vignaud2002-09-171-1/+1
|
* add ignore option to msec itemsThierry Vignaud2002-09-171-3/+3
|
* - draksec window title is draksec, not "draksec - basic options" since it offerThierry Vignaud2002-09-122-11/+14
| | | | | | advanced options too now - mark some strings to be translated (mainly notebook pages titles)
* improved i18n handlingPablo Saratxaga2002-09-101-5/+5
|
* inline seclevel_explain (why using functions to return a text label ?)Thierry Vignaud2002-09-102-24/+16
|
* move back draksec's files in drakxtoolsThierry Vignaud2002-09-103-0/+672
|
* - draksec is in his own package nowChristian Belisle2002-08-193-349/+0
|
* - draksec is in his own package now.Christian Belisle2002-08-191-18/+0
|
* shorewall-related functions will go here.Christian Belisle2002-08-071-0/+0
|
* - Fix page change between checks -> advancedChristian Belisle2002-07-311-1/+2
|
* - Factorize options-related functionsChristian Belisle2002-07-312-29/+106
| | | | | | - s/choose_options/choose_functions - Added security checks page
* - factorize functions (many functions -> one function)Christian Belisle2002-07-311-34/+31
|