summaryrefslogtreecommitdiffstats
path: root/perl-install/fs.pm
Commit message (Collapse)AuthorAgeFilesLines
* fsedit::is_same_hd is now fs:get::is_same_hdPascal Rigaux2005-06-131-2/+2
|
* fs::auto_fs() is now fs::type::guessed_by_mount() (still not a really nice ↵Pascal Rigaux2005-06-131-4/+0
| | | | name...)
* don't need use MDK::Common... when we have "use common" (which is the ↵Pascal Rigaux2005-06-101-2/+0
| | | | standard for libDrakX modules)
* move loopback.pm to fs/loopback.pmPascal Rigaux2005-06-101-8/+8
| | | | | (since it's tightly tight to many fs* things)
* (mount_part) stop removing lost+found (#16173) (pixel's changelog was ↵Thierry Vignaud2005-06-081-1/+0
| | | | "no_comment")
* (mount) use 'soft' & 'intr' options for nfs mountsThierry Vignaud2005-06-071-1/+1
|
* handle nfs mount (since we now use the /bin/mount instead of the syscall, we ↵Pascal Rigaux2005-06-071-2/+4
| | | | get it for free)
* merge_fstabs doesn't mess around with options anymore in "loose" modePascal Rigaux2005-06-011-1/+0
|
* ensure reading existing fstab in suggest_mount_points doesn't get its optionsPascal Rigaux2005-06-011-4/+7
|
* nicer logPascal Rigaux2005-06-011-1/+1
|
* use command mount instead of using directly the syscall (allows some cleanup)Pascal Rigaux2005-06-011-56/+60
|
* (mount) let's support ntfs and reorder fs list btw (#3653)Thierry Vignaud2005-02-091-2/+2
|
* new kernel doesn't like usbdevfs any more, it wants usbfsPascal Rigaux2005-02-081-1/+8
|
* - create fs::type::directories_needed_to_boot() and use itPascal Rigaux2005-01-281-1/+1
| | | | | | - for removable drives used for / /usr and the like, ensure we check it at boot time (bugzilla #13283)
* fs::formatMount_all() parameter wait_message is no more optional (though you ↵Pascal Rigaux2005-01-061-2/+2
| | | | can give undef)
* part2wild_device_name('', $part) is better than ↵Pascal Rigaux2005-01-051-1/+1
| | | | devices::make($part->{device}) (esp. for nfs "devices")
* handle spaces in usernamePascal Rigaux2005-01-051-4/+2
|
* - fs::mount() wants a real device or a faked one, but doesn't accept things ↵Pascal Rigaux2004-12-211-5/+6
| | | | | | | | like fd0 anymore (give it /dev/fd0) - a little more robust analyze_wild_device_name() during install - handle bad things in subpart_from_wild_device_name()
* better english (writing style rather than spoken one)Thierry Vignaud2004-12-131-5/+5
|
* remove unused varPascal Rigaux2004-11-251-2/+0
|
* we don't use /tmp for devices anymorePascal Rigaux2004-11-251-2/+2
| | | | | (this comes from long ago when redhat code was using a ro /dev and creating other devices in /tmp)
* - create analyze_wild_device_name() out of subpart_from_wild_device_name()Pascal Rigaux2004-11-251-40/+66
| | | | | | | | | | - rename part2device() into part2wild_device_name(), change its prototype and use analyze_wild_device_name() - new field {faked_device} - for LABEL=..., {device} is not empty anymore and {faked_device} is set, merge_fstabs() will take care of having the real {device} and {faked_device} unset - for devfs_device, {device} is set to the devfs device, merge_fstabs() will take care of having the non devfs device in {device}
* more intelligent sort of fstab to handle loopback files or bind directory ↵Pascal Rigaux2004-11-251-3/+22
| | | | (bug anthil #1198)
* fix {device_alias} containing /dev/xxx instead of xxx. The bug wasPascal Rigaux2004-11-231-6/+6
| | | | | | "none /mnt/cdrom supermount dev=/dev//dev/cdrom,fs=iso9660..." (bugzilla #12224)
* since we don't use ramdisk but clp, some code is deadPascal Rigaux2004-11-181-1/+1
| | | | | (remove usingRamdisk(), check_prog(), remove_unused()...)
* remove some unneeded ";", add some for normalization (as told by perl_checker)Pascal Rigaux2004-11-181-3/+3
|
* fix typoPascal Rigaux2004-09-271-1/+1
|
* silently ignore encrypted filesystems with no encrypt_keyPascal Rigaux2004-09-221-0/+3
|
* don't add /dev/pts line in fstab anymore (it's done in initrd and udev)Pascal Rigaux2004-09-221-1/+0
|
* perl_checker compliancePascal Rigaux2004-09-201-1/+1
|
* - add field {part_number} for partitionsPascal Rigaux2004-09-201-2/+8
| | | | | | | | | | | (handle it in subpart_from_wild_device_name(), partition_table::read()) - create migrate_device_names() to handle the change of device names when changing kernel&modules (eg: hde->hda or hda->sda) - change prototype of install_any::use_root_part() (prefix is dropped, optional $in is added) - create fs::type::can_be_this_fs_type() and use it - create devices::part_number() and devices::part_prefix() and use them
* - don't use fs::get_info_from_fstab() in install_any::use_root_part() to be ↵Pascal Rigaux2004-09-201-3/+2
| | | | | | | | | able to handle renamed devices - fs::get_info_from_fstab() doesn't take a prefix anymore - small perl_checker fix in install_any.pm
* - ignore first line of /proc/swapsPascal Rigaux2004-09-071-3/+8
| | | | | | | - partially handle /udev/xxx device names in fstab - ignore rootfs "device" - don't warn for loopback files
* enhance based on perl_checker suggestion, but not using it :)Pascal Rigaux2004-08-121-3/+2
|
* allow 192.168.1.1:/exportPascal Rigaux2004-08-091-1/+1
|
* move mount options related stuff from fs.pm to newly created fs/mount_options.pmPascal Rigaux2004-08-031-242/+3
| | | | | | | | | | | - fs::set_all_default_options() -> fs::mount_options::set_all_default() - fs::mount_options_pack() -> fs::mount_options::pack() - fs::mount_options_unpack() -> fs::mount_options::unpack() - fs::rationalize_options() -> fs::mount_options::rationalize() - fs::set_default_options() -> fs::mount_options::set_default() - fs::mount_options() -> fs::mount_options::list() - fs::mount_options_help() -> fs::mount_options::help()
* *** empty log message ***Pascal Rigaux2004-08-031-1/+2
|
* many functions in fsedit don't modify anything, they are simply accessors.Pascal Rigaux2004-08-031-24/+7
| | | | | | | | | | | | | | | | | | | | | | | | create fs::get and move them into it - device2part(), up_mount_point() moved from fs to fs::get - part2hd(), file2part(), has_mntpoint(), mntpoint2part(), empty_all_hds() moved from fsedit to fs::get - fsedit::get_root() -> fs::get::root() - fsedit::get_root_() -> fs::get::root_() - fsedit::get_really_all_fstab() -> fs::get::really_all_fstab() - fsedit::get_all_fstab_and_holes() -> fs::get::fstab_and_holes() - fsedit::get_all_fstab() -> fs::get::fstab() - fsedit::get_all_holes() -> fs::get::holes() - fsedit::all_free_space -> fs::get::free_space() - fsedit::get_really_all_fstab() -> fs::get::really_all_fstab() - fsedit::get_fstab_and_holes() -> fs::get::hds_fstab_and_holes() - fsedit::get_holes() -> fs::get::hds_holes() - fsedit::get_fstab() -> fs::get::hds_fstab() - fsedit::free_space() -> fs::get::hds_free_space() - fsedit::get_visible_fstab() unused, removed
* don't use supermount for {is_removable} devices when used for a boot time ↵Pascal Rigaux2004-08-021-1/+1
| | | | partition (like /usr and /)
* - add field {fs_type} partially replacing {pt_type}Pascal Rigaux2004-07-271-48/+47
| | | | | | | | | | | | | | | | | | | | {pt_type} is always a number, {fs_type} is always a string - introduce set_isFormatted() (to ensure {notFormatted} but also {fs_type_from_magic} and {bad_fs_type_magic} are updated) - don't use 0x483 for ext3 anymore (same for reiserfs...), the type_name gives both a pt_type and a fs_type - many accessors from partition_table removed (type2fs(), fs2pt_type()) - remove isThisFs() (not useful anymore since we can use directly {fs_type}) - remove isFat() (inline the function) - other isXXX() from partition_table are moved to fs::type - part2name() is now fs::type::part2type_name - name2pt_type() is now fs::type::type_name2subpart() - partition_table::important_types() is now fs::type::type_names() - fsedit::typeOfPart() is now fs::type::fs_type_from_magic() - no need to truncate type_name since they are shorter
* replace pt_type2name($part->{pt_type}) with part2name($part)Pascal Rigaux2004-07-231-1/+1
| | | | | (hoisting the dereferencing {pt_type})
* - move format related functions out of fs.pm to new module fs/format.pmPascal Rigaux2004-07-231-103/+15
| | | | | - remove swap.pm, moving its few functions to fs/format.pm or fs.pm
* set {is_removable} directly in fsedit::hds()Pascal Rigaux2004-07-221-1/+0
|
* big renaming of field {type} to {pt_type},Pascal Rigaux2004-07-051-30/+30
| | | | | | this will allow defining {fs_type} which will always be a string whereas {pt_type} will always be a number
* create rationalize_options() and use it (bugzilla #3525)Pascal Rigaux2004-07-051-2/+15
| | | | | more checks should be done in this function, and used at more places (but where?)
* don't set {major} and {minor} to 0 when the device doesn't existPascal Rigaux2004-07-051-1/+3
|
* use fsedit::is_same_hd in drakupdate_fstab and revert previous change in ↵Olivier Blin2004-06-291-2/+2
| | | | fs::subpart_from_wild_device_name (do not fill both devfs_device and device fields)
* do not add default device in device hash, it will be filled with result from ↵Olivier Blin2004-06-291-1/+1
| | | | fs::subpart_from_wild_device_name
* always update $part{device} in fs::subpart_from_wild_device_name because ↵Olivier Blin2004-06-291-2/+2
| | | | /dev is stripped (fix #6982, #10175)
* - enhance subpart_from_wild_device_name() to handle "sda" the same as ↵Pascal Rigaux2004-06-251-21/+35
| | | | | | | | | "/dev/sda" (when /dev/sda exists) - new function device2part() which uses subpart_from_wild_device_name and the given fstab to convert the device name to the corresponding structure (this allows not relying too much on the device name)