aboutsummaryrefslogtreecommitdiffstats
path: root/mandrake_desk.spec
diff options
context:
space:
mode:
Diffstat (limited to 'mandrake_desk.spec')
-rw-r--r--mandrake_desk.spec19
1 files changed, 19 insertions, 0 deletions
diff --git a/mandrake_desk.spec b/mandrake_desk.spec
index 5a931d5..f440f80 100644
--- a/mandrake_desk.spec
+++ b/mandrake_desk.spec
@@ -35,6 +35,25 @@ find . -type 'd' -name 'CVS' | xargs rm -fr
rm -rf %buildroot
+## Install backgrounds
+# User & root's backgrounds
+install -d -m 0755 %buildroot/%_datadir/mdk/backgrounds/root/
+install -m 0644 backgrounds/default.png %buildroot/%_datadir/mdk/backgrounds/default.png
+install -m 0644 backgrounds/default-root.png %buildroot/%_datadir/mdk/backgrounds/root/default.png
+
+# XFdrake test card
+install -d -m 0755 %buildroot/%_datadir/mdk/xfdrake/
+install -m 0644 backgrounds/xfdrake-test-card.jpg %buildroot/%_datadir/mdk/xfdrake/xfdrake-test-card.jpg
+
+
+## Install scripts
+install -d -m 0755 %buildroot/%_bindir/
+for i in bin/*.sh ; do install -m 0755 $i %buildroot/_bindir/ ; done
+
+
+
+
+
## Install faces
install -d 0755 %buildroot/%_datadir/faces/
cp %buildroot/%_datadir/mdk/faces/default.png %buildroot/%_datadir/faces/default.png