aboutsummaryrefslogtreecommitdiffstats
path: root/eazel-engine/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'eazel-engine/Makefile.am')
-rw-r--r--eazel-engine/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/eazel-engine/Makefile.am b/eazel-engine/Makefile.am
new file mode 100644
index 0000000..c6bda1c
--- /dev/null
+++ b/eazel-engine/Makefile.am
@@ -0,0 +1,22 @@
+SUBDIRS = src capplet data Crux
+
+INCLUDES = $(GTK_CFLAGS) $(GNOME_CFLAGS) -DDATADIR=\"$(datadir)\"
+
+EXTRA_DIST = \
+ gtkrc.in \
+ make-gtkrc.pl \
+ test.glade \
+ eazel-engine.spec.in \
+ check-data.sh
+
+dist-hook: spec-hook check-data
+
+spec-hook : eazel-engine.spec
+ cp $^ $(distdir)
+
+check-data : check-data.sh
+ $(SHELL) $<
+
+noinst_PROGRAMS = test
+
+test_LDADD = $(GTK_LIBS) $(GNOME_LIBS)