summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Whitaker <mageia@martin-whitaker.me.uk>2019-02-03 21:06:50 +0000
committerMartin Whitaker <mageia@martin-whitaker.me.uk>2019-02-16 21:39:08 +0000
commit725103117a28269c68c228dac04ee5ff94c74510 (patch)
tree5f4a4d67dc79595282f83a152871cda983cc2918
parent54ad04fef3e0a695d47d5a70d5689a6c99b4c18d (diff)
drakclassic: show package dependencies at verbose level > 4.
-rw-r--r--NEWS2
-rw-r--r--lib/MGA/DrakISO/BuildMedia.pm2
2 files changed, 4 insertions, 0 deletions
diff --git a/NEWS b/NEWS
index 1eab9cc..0e46379 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,5 @@
+- drakclassic: show package dependencies at verbose level > 4
+
1.9
- bootloader: make it clear that non-free drivers are only for NVIDIA
diff --git a/lib/MGA/DrakISO/BuildMedia.pm b/lib/MGA/DrakISO/BuildMedia.pm
index 02f7049..dced6e5 100644
--- a/lib/MGA/DrakISO/BuildMedia.pm
+++ b/lib/MGA/DrakISO/BuildMedia.pm
@@ -395,6 +395,7 @@ sub update_dependencies() {
my @search_list = grep { $package{$_}{class} == 1 } keys %package;
while (@search_list) {
foreach my $name (@search_list) {
+ print " dependencies for $name:\n" if $::verbose > 4;
my $pkg = $package{$name}{best_pkg};
my $parent_name = $pkg->name;
my @requires = $pkg->requires_nosense;
@@ -422,6 +423,7 @@ sub update_dependencies() {
$name = $latest_name if $parent_name ne $latest_name;
}
return if member($name, @excluded);
+ print " $name\n" if $::verbose > 4;
$package{$name} or die "ERROR: $name is not available in the urpmi media\n";
$package{$name}{class} = 3 if !defined $package{$name}{class};
});