summaryrefslogtreecommitdiffstats
path: root/t/data/SPECS/rpm-query-in-scriptlet.spec
diff options
context:
space:
mode:
Diffstat (limited to 't/data/SPECS/rpm-query-in-scriptlet.spec')
-rw-r--r--t/data/SPECS/rpm-query-in-scriptlet.spec31
1 files changed, 31 insertions, 0 deletions
diff --git a/t/data/SPECS/rpm-query-in-scriptlet.spec b/t/data/SPECS/rpm-query-in-scriptlet.spec
new file mode 100644
index 00000000..dc331998
--- /dev/null
+++ b/t/data/SPECS/rpm-query-in-scriptlet.spec
@@ -0,0 +1,31 @@
+Summary: x
+Name: rpm-query-in-scriptlet
+Version: 1
+Release: 1
+License: x
+Group: x
+Url: x
+BuildRoot: %{_tmppath}/%{name}
+
+%description
+x
+
+%install
+rm -rf %buildroot
+echo > list
+for i in sh rpm; do
+ bin=`which $i`
+ echo $bin >> list
+ ldd $bin | sed -e 's/^[ \t]*//' -e 's/.* => //' -e 's/ .*//' >> list
+done
+grep '/' list | (cd / ; cpio -pumd --dereference %buildroot)
+
+find %buildroot
+
+%post
+echo "RPMLOCK_NOWAIT is '$RPMLOCK_NOWAIT'"
+rpm -q foo
+true
+
+%files
+/*