summaryrefslogtreecommitdiffstats
path: root/t/data/SPECS/buildroot_default.spec
diff options
context:
space:
mode:
Diffstat (limited to 't/data/SPECS/buildroot_default.spec')
-rw-r--r--t/data/SPECS/buildroot_default.spec4
1 files changed, 4 insertions, 0 deletions
diff --git a/t/data/SPECS/buildroot_default.spec b/t/data/SPECS/buildroot_default.spec
index e1fc7c78..94f10ded 100644
--- a/t/data/SPECS/buildroot_default.spec
+++ b/t/data/SPECS/buildroot_default.spec
@@ -22,10 +22,14 @@ Release: 2
x
%install
+%if %{rpm_version} >= 500
+echo This is Mandriva specific, skipping it for rpm5.org...
+%else
wanted=$(echo %{_tmppath}/buildroot-1-1-buildroot | sed 's!//!/!')
[ "%buildroot" = $wanted ] || { echo "buildroot should be $wanted instead of %buildroot"; exit 1; }
[ "$RPM_BUILD_ROOT" = $wanted ] || { echo "RPM_BUILD_ROOT should be $wanted instead of $RPM_BUILD_ROOT"; exit 1; }
[ "%macro_using_buildroot" = $wanted ] || { echo "macro_using_buildroot should be $wanted instead of %buildroot"; exit 1; }
+%endif
install -d $RPM_BUILD_ROOT/etc
echo foo > $RPM_BUILD_ROOT/etc/foo