summaryrefslogtreecommitdiffstats
path: root/t/SPECS
diff options
context:
space:
mode:
Diffstat (limited to 't/SPECS')
-rw-r--r--t/SPECS/arch_to_noarch_1.spec28
-rw-r--r--t/SPECS/arch_to_noarch_2.spec28
-rw-r--r--t/SPECS/arch_to_noarch_3.spec29
-rw-r--r--t/SPECS/arch_to_noarch_4.spec28
-rw-r--r--t/SPECS/various.spec38
5 files changed, 151 insertions, 0 deletions
diff --git a/t/SPECS/arch_to_noarch_1.spec b/t/SPECS/arch_to_noarch_1.spec
new file mode 100644
index 00000000..05cff446
--- /dev/null
+++ b/t/SPECS/arch_to_noarch_1.spec
@@ -0,0 +1,28 @@
+Summary: arch_to_noarch
+Name: arch_to_noarch
+Version: 1
+Release: 1
+License: x
+Group: x
+Url: x
+BuildRoot: %{_tmppath}/%{name}
+
+%prep
+
+%build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT/usr/lib/test-%{name}
+cp /sbin/ldconfig $RPM_BUILD_ROOT/usr/lib/test-%{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%description
+this pkg own a binary file
+
+%files
+%defattr(-,root,root)
+%config(noreplace) /usr/lib/test-%{name}
+
diff --git a/t/SPECS/arch_to_noarch_2.spec b/t/SPECS/arch_to_noarch_2.spec
new file mode 100644
index 00000000..7be6925b
--- /dev/null
+++ b/t/SPECS/arch_to_noarch_2.spec
@@ -0,0 +1,28 @@
+Summary: arch_to_noarch
+Name: arch_to_noarch
+Version: 2
+Release: 1
+License: x
+Group: x
+Url: x
+BuildRoot: %{_tmppath}/%{name}
+
+%prep
+
+%build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT/usr/lib/test-%{name}
+cp /sbin/ldconfig $RPM_BUILD_ROOT/usr/lib/test-%{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%description
+this pkg still owns a binary file
+
+%files
+%defattr(-,root,root)
+%config(noreplace) /usr/lib/test-%{name}
+
diff --git a/t/SPECS/arch_to_noarch_3.spec b/t/SPECS/arch_to_noarch_3.spec
new file mode 100644
index 00000000..be9cdb4d
--- /dev/null
+++ b/t/SPECS/arch_to_noarch_3.spec
@@ -0,0 +1,29 @@
+Summary: arch_to_noarch
+Name: arch_to_noarch
+Version: 3
+Release: 1
+License: x
+Group: x
+Url: x
+BuildRoot: %{_tmppath}/%{name}
+BuildArch: noarch
+
+%prep
+
+%build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT/usr/lib/test-%{name}
+echo foo > $RPM_BUILD_ROOT/usr/lib/test-%{name}/foo
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%description
+this pkg is now a noarch
+
+%files
+%defattr(-,root,root)
+%config(noreplace) /usr/lib/test-%{name}
+
diff --git a/t/SPECS/arch_to_noarch_4.spec b/t/SPECS/arch_to_noarch_4.spec
new file mode 100644
index 00000000..7eb32705
--- /dev/null
+++ b/t/SPECS/arch_to_noarch_4.spec
@@ -0,0 +1,28 @@
+Summary: arch_to_noarch
+Name: arch_to_noarch
+Version: 4
+Release: 1
+License: x
+Group: x
+Url: x
+BuildRoot: %{_tmppath}/%{name}
+
+%prep
+
+%build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT/usr/lib/test-%{name}
+cp /sbin/ldconfig $RPM_BUILD_ROOT/usr/lib/test-%{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%description
+this pkg is now a binary again
+
+%files
+%defattr(-,root,root)
+%config(noreplace) /usr/lib/test-%{name}
+
diff --git a/t/SPECS/various.spec b/t/SPECS/various.spec
new file mode 100644
index 00000000..b7d62e8f
--- /dev/null
+++ b/t/SPECS/various.spec
@@ -0,0 +1,38 @@
+Summary: various
+Name: various
+Version: 1
+Release: 1
+License: x
+Group: x
+Url: x
+BuildRoot: %{_tmppath}/%{name}
+
+%prep
+echo foo > foo
+
+%build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+for i in /etc/test-%{name} \
+ /var/lib/test-%{name}/foo1 /var/lib/test-%{name}/foo2 /var/lib/test-%{name}/foo3 \
+ /usr/share/locale/fr/LC_MESSAGES/test-%{name}.mo \
+ /usr/test-%{name}/foo; do
+ install -d `dirname $RPM_BUILD_ROOT$i`
+ echo foo > $RPM_BUILD_ROOT$i
+done
+
+%find_lang test-%{name}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%description
+x
+
+%files -f test-%{name}.lang
+%defattr(-,root,root)
+%doc foo
+%config(noreplace) /etc/*
+/var/lib/*
+/usr/test-%{name}