summaryrefslogtreecommitdiffstats
path: root/urpmi.spec
diff options
context:
space:
mode:
authorRafael Garcia-Suarez <rgarciasuarez@mandriva.org>2005-04-15 15:05:56 +0000
committerRafael Garcia-Suarez <rgarciasuarez@mandriva.org>2005-04-15 15:05:56 +0000
commit6155589401cc39b6711cab917820c4d4f867b528 (patch)
tree46d85c53e03ba1a9c995b76cc56971fd08980e1a /urpmi.spec
parenta813caa075959e2cfc03ece726ee529b939b6aff (diff)
downloadurpmi-6155589401cc39b6711cab917820c4d4f867b528.tar
urpmi-6155589401cc39b6711cab917820c4d4f867b528.tar.gz
urpmi-6155589401cc39b6711cab917820c4d4f867b528.tar.bz2
urpmi-6155589401cc39b6711cab917820c4d4f867b528.tar.xz
urpmi-6155589401cc39b6711cab917820c4d4f867b528.zip
Be less dependent on vendor name ; rename distribution
Diffstat (limited to 'urpmi.spec')
-rw-r--r--urpmi.spec22
1 files changed, 10 insertions, 12 deletions
diff --git a/urpmi.spec b/urpmi.spec
index dd41fb73..a1ca328c 100644
--- a/urpmi.spec
+++ b/urpmi.spec
@@ -10,25 +10,23 @@
%define version 4.6.24
%define release 3mdk
-%define group %(perl -e 'printf "%%s\\n", "%_vendor" =~ /mandrake/i ? "System/Configuration/Packaging" : "System Environment/Base"')
+%define group %(perl -e 'print "%_vendor" =~ /\\bmandr/i ? "System/Configuration/Packaging" : "System Environment/Base"')
-%{expand:%%define compat_perl_vendorlib %(perl -MConfig -e 'printf "%%s\n", "%{?perl_vendorlib:1}" ? "%%{perl_vendorlib}" : "$Config{installvendorlib}"')}
-%{expand:%%define use_locale %%(perl -e 'printf "%%s\\n", "%_vendor" =~ /mandrake/i ? 1 : 0')}
-%{expand:%%define allow_gurpmi %%(perl -e 'printf "%%s\\n", "%_vendor" =~ /mandrake/i ? 1 : 0')}
-%{expand:%%define req_webfetch %%(perl -e 'printf "%%s\\n", "%_vendor" =~ /mandrake/i ? "webfetch" : "curl wget"')}
-%{expand:%%define buildreq_locale %%(perl -e 'printf "%%s\\n", "%_vendor" =~ /mandrake/i ? "perl-MDK-Common-devel" : ""')}
-%{expand:%%define distribution %%(perl -e 'printf "%%s\\n", ("%_vendor" =~ /mandrake/i ? "Mandrakelinux" : "Red Hat Linux")')}
-%{expand:%%define real_release %%(perl -e 'printf "%%s\\n", ("%_vendor" !~ /mandrake/i && ("%release" =~ /(.*?)mdk/)[0] || "%release")')}
+%{expand:%%define compat_perl_vendorlib %(perl -MConfig -e 'print "%{?perl_vendorlib:1}" ? "%%{perl_vendorlib}" : "$Config{installvendorlib}"')}
+%{expand:%%define use_locale %%(perl -e 'print "%_vendor" =~ /\\bmandr/i ? 1 : 0')}
+%{expand:%%define allow_gurpmi %%(perl -e 'print "%_vendor" =~ /\\bmandr/i ? 1 : 0')}
+%{expand:%%define req_webfetch %%(perl -e 'print "%_vendor" =~ /\\bmandr/i ? "webfetch" : "curl wget"')}
+%{expand:%%define buildreq_locale %%(perl -e 'print "%_vendor" =~ /\\bmandr/i ? "perl-MDK-Common-devel" : ""')}
+%{expand:%%define real_release %%(perl -e 'print "%_vendor" =~ /\\bmandr/i ? "%release" : ("%release" =~ /(\d+)/)[0]')}
Name: %{name}
Version: %{version}
Release: %{real_release}
Group: %{group}
-Distribution: %{distribution}
License: GPL
Source0: %{name}.tar.bz2
Summary: Command-line software installation tools
-URL: http://cvs.mandrakesoft.com/cgi-bin/cvsweb.cgi/soft/urpmi
+URL: http://cvs.mandriva.com/cgi-bin/cvsweb.cgi/soft/urpmi
Requires: %{req_webfetch} eject gnupg
Requires(pre): perl-Locale-gettext >= 1.01-14mdk
Requires(pre): rpmtools >= 4.5
@@ -43,13 +41,13 @@ Conflicts: rpmdrake < 2.4-2mdk
Conflicts: curl < 7.13.0
%description
-urpmi is Mandrakelinux's console-based software installation tool. You can
+urpmi is Mandrivalinux's console-based software installation tool. You can
use it to install software from the console in the same way as you use the
graphical Install Software tool (rpmdrake) to install software from the
desktop. urpmi will follow package dependencies -- in other words, it will
install all the other software required by the software you ask it to
install -- and it's capable of obtaining packages from a variety of media,
-including the Mandrakelinux installation CD-ROMs, your local hard disk,
+including the Mandrivalinux installation CD-ROMs, your local hard disk,
and remote sources such as web or FTP sites.
%if %{allow_gurpmi}