aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorFrancois Pons <fpons@mandriva.com>2000-08-25 14:49:48 +0000
committerFrancois Pons <fpons@mandriva.com>2000-08-25 14:49:48 +0000
commitf8b245f06572634f7b7ad20dfb91736b10da7343 (patch)
treeddbed7047fbca6d22f5d03a6e2f25e85426a432d /Makefile.PL
parent553269fd36cf7107ae6ebca135d1df2fc0e0c2b0 (diff)
downloadrpmtools-f8b245f06572634f7b7ad20dfb91736b10da7343.tar
rpmtools-f8b245f06572634f7b7ad20dfb91736b10da7343.tar.gz
rpmtools-f8b245f06572634f7b7ad20dfb91736b10da7343.tar.bz2
rpmtools-f8b245f06572634f7b7ad20dfb91736b10da7343.tar.xz
rpmtools-f8b245f06572634f7b7ad20dfb91736b10da7343.zip
*** empty log message ***
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..9e62f5e
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,16 @@
+use ExtUtils::MakeMaker;
+# See lib/ExtUtils/MakeMaker.pm for details of how to influence
+# the contents of the Makefile that is written.
+
+my $libs = ' -lrpm -ldb1 -lz';
+
+WriteMakefile(
+ 'NAME' => 'rpmtools',
+ 'OPTIMIZE' => '-O3 -fomit-frame-pointer -fno-exceptions -fno-rtti -pipe -s -mpentium -mcpu=pentium -march=pentium -ffast-math -fexpensive-optimizations',
+ 'MAKEFILE' => 'Makefile_core',
+ 'OBJECT' => 'rpmtools.o',
+ 'VERSION_FROM' => 'rpmtools.pm',
+ 'LIBS' => [$libs], # e.g., '-lm'
+ 'INC' => '-I/usr/include/rpm', # e.g., '-I/usr/include/other'
+);
+