aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 21 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 4dfaf6f..995d1ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,9 +1,8 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-
-AC_PREREQ(2.59)
-AC_INIT(rpm-mageia-setup, 2.38, https://bugs.mageia.org/)
+AC_PREREQ([2.69])
+AC_INIT([rpm-mageia-setup],[2.78],[https://bugs.mageia.org/])
AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE(1.9 -Wno-portability foreign no-dist-gzip dist-xz)
AC_CONFIG_SRCDIR
@@ -12,7 +11,7 @@ AC_CONFIG_MACRO_DIR([m4])
# Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
-AC_PROG_LIBTOOL
+LT_INIT
AC_CONFIG_FILES([
Makefile
])
@@ -20,6 +19,7 @@ AC_CONFIG_FILES([
dnl See if we have pkgconfig for rpm, resort to old behavior if not
PKG_CHECK_MODULES([RPM], [rpm], [
AC_DEFINE_UNQUOTED([HAVE_RPM],1,[Define if RPM backend is available])
+ AC_CHECK_HEADERS([rpm/rpmlib.h])
CPPFLAGS="$RPM_CFLAGS $CPPFLAGS"
LDFLAGS="$RPM_LIBS $LDFLAGS"
], [
@@ -33,7 +33,7 @@ PKG_CHECK_MODULES([RPM], [rpm], [
)
AC_CHECK_LIB([rpmio], [rpmLoadMacroFile])
-AC_HEADER_STDC
+
AC_CHECK_HEADERS([string.h])
CANONTARGETCPU=${target_cpu}
@@ -42,14 +42,18 @@ ARMV7CANONTARGETCPU="armv5tl"
ARMV8CANONTARGETCPU="armv8l"
case "${target_cpu}" in
- *86|athlon|k6|pentium*)
+ i[3,4,5]86|athlon|k6|pentium3)
RPMALLARCH="i386 i486 i586 i686 k6 athlon pentium3 pentium4"
CANONTARGETCPU=i586
;;
+ i686|pentium4)
+ RPMALLARCH="i386 i486 i586 i686 k6 athlon pentium3 pentium4"
+ CANONTARGETCPU=i686
+ ;;
x86_64|amd64)
RPMALLARCH="i386 i486 i586 i686 k6 athlon pentium3 pentium4 amd64 x86_64"
CANONTARGETCPU=x86_64
- CANONTARGETCPU32=i586
+ CANONTARGETCPU32=i686
;;
ppc|powerpc)
RPMALLARCH="ppc"
@@ -103,6 +107,13 @@ case "${target_cpu}" in
CANONTARGETGNU=-gnueabi
ARMV7CANONTARGETCPU="armv7hl"
ARMV8CANONTARGETCPU="armv7hl"
+ ;;
+ armv8*)
+ RPMALLARCH="armv7hl"
+ CANONTARGETCPU=armv7hl
+ CANONTARGETGNU=-gnueabi
+ ARMV7CANONTARGETCPU="armv7hl"
+ ARMV8CANONTARGETCPU="armv7hl"
esac
RPMALLARCH="${RPMALLARCH} noarch"
AC_SUBST(RPMALLARCH)
@@ -177,12 +188,11 @@ RPMVENDORDIR="${RPMCONFDIR}/${RPMCANONVENDOR}"
AC_SUBST(RPMVENDORDIR)
RPMSYSCONFDIR="/etc/rpm"
-AC_ARG_WITH(rpmsysconfdir, [ --with-rpmsysconfdir=dir location of etc ])
-if test $with_rpmsysconfdir; then
- RPMSYSCONFDIR=$with_rpmsysconfdir
-fi
AC_SUBST(RPMSYSCONFDIR)
+RPMMACROSD="/usr/lib/rpm/macros.d"
+AC_SUBST(RPMMACROSD)
+
AC_ARG_WITH(rpmplatform, [ --with-rpmplatform use /etc/rpm/platform ])
AM_CONDITIONAL([RPMPLATFORM],[test $with_rpmplatform])