aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 1873d42..cb6dd30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,8 +1,8 @@
# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.59)
-AC_INIT(rpm-mageia-setup, 2.61, https://bugs.mageia.org/)
+AC_PREREQ([2.69])
+AC_INIT([rpm-mageia-setup],[2.61],[https://bugs.mageia.org/])
AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE(1.9 -Wno-portability foreign no-dist-gzip dist-xz)
AC_CONFIG_SRCDIR
@@ -11,7 +11,7 @@ AC_CONFIG_MACRO_DIR([m4])
# Checks for programs.
AC_PROG_CC
AC_PROG_INSTALL
-AC_PROG_LIBTOOL
+LT_INIT
AC_CONFIG_FILES([
Makefile
])
@@ -32,7 +32,7 @@ PKG_CHECK_MODULES([RPM], [rpm], [
)
AC_CHECK_LIB([rpmio], [rpmLoadMacroFile])
-AC_HEADER_STDC
+
AC_CHECK_HEADERS([string.h])
CANONTARGETCPU=${target_cpu}
@@ -41,7 +41,7 @@ ARMV7CANONTARGETCPU="armv5tl"
ARMV8CANONTARGETCPU="armv8l"
case "${target_cpu}" in
- *86|athlon|k6|pentium*)
+ *86|athlon|k6|pentium*)
RPMALLARCH="i386 i486 i586 i686 k6 athlon pentium3 pentium4"
CANONTARGETCPU=i586
;;