aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bce1b20..d7374e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,11 +10,17 @@ AM_INIT_AUTOMAKE(1.9)
AC_CONFIG_SRCDIR
# Checks for programs.
+AC_PROG_CC
AC_PROG_INSTALL
+AC_PROG_LIBTOOL
AC_CONFIG_FILES([
Makefile
])
+AC_CHECK_LIB([rpmio], [rpmLoadMacroFile])
+AC_HEADER_STDC
+AC_CHECK_HEADERS([string.h rpm/rpmmacros.h rpm/rpmlib.h])
+
case "${target_cpu}" in
*86|athlon|k6)
RPMALLARCH="i386 i486 i586 i686 k6 athlon pentium3 pentium4"
@@ -99,4 +105,5 @@ if test $with_rpmsysconfdir; then
fi
AC_SUBST(RPMSYSCONFDIR)
+
AC_OUTPUT