aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 19 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 3fd71e1..27e2844 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,6 +11,11 @@ pkg_gdata = \
pkg_data_in = $(pkg_gdata:=.in)
+pkg_gconfig = \
+ platform
+
+pkg_gconfig_in = $(pkg_gconfig:=.in)
+
pkg_scripts = \
brp-compress \
brp-strip \
@@ -32,6 +37,7 @@ pkg_gscripts = \
find-provides \
find-requires \
find-provides.perl
+
pkg_scripts_in = $(pkg_gscripts:=.in)
BUILT_SOURCES = macros-perarch make_macrosfiles.sh
@@ -44,9 +50,12 @@ rpmeval_SOURCES = rpmeval.c
rpmeval_LDFLAGS = -lrpm
+noinst_DATA = $(pkg_gconfig)
+
pkglib_DATA = \
$(pkg_data) \
$(pkg_gdata)
+ $(pkg_gconfig)
pkglib_SCRIPTS = \
$(pkg_scripts) \
@@ -57,6 +66,7 @@ EXTRA_DIST = \
$(pkg_data_in) \
$(pkg_scripts) \
$(pkg_scripts_in) \
+ $(pkg_gconfig_in) \
macros-perarch.in make_macrosfiles.sh.in \
rpm-spec-mode.el \
tests.sh tests/macros.sh
@@ -67,7 +77,8 @@ edit = sed \
-e 's,@RPMCANONVENDOR\@,$(RPMCANONVENDOR),g' \
-e 's,@RPMLIBDIR\@,$(RPMLIBDIR),g' \
-e 's,@RPMSYSCONFDIR\@,$(RPMSYSCONFDIR),g'\
- -e 's,@RPMOS\@,$(RPMOS),g'
+ -e 's,@RPMOS\@,$(RPMOS),g' \
+ -e 's,@CANONTARGETCPU\@,$(CANONTARGETCPU),g'
%: %.in Makefile
$(edit) $< > $@
@@ -76,11 +87,15 @@ edit = sed \
arch=`echo $@ | sed 's,\\.macros,,'`; \
sh ./make_macrosfiles.sh macros-perarch $$arch > $@
-install-data-local: $(macrosfiles)
+install-data-local: $(macrosfiles) $(pkg_gconfig)
for i in $(RPMALLARCH); do \
$(mkinstalldirs) $(DESTDIR)$(RPMVENDORDIR)/$${i}-$(RPMOS); \
$(install_sh_DATA) $${i}.macros $(DESTDIR)$(RPMVENDORDIR)/$${i}-$(RPMOS)/macros; \
done
+ [ -d $(DESTDIR)$(RPMSYSCONFDIR) ] || $(mkinstalldirs) $(DESTDIR)$(RPMSYSCONFDIR)
+ for i in $(pkg_gconfig); do \
+ $(install_sh_DATA) $${i} $(DESTDIR)$(RPMSYSCONFDIR)/$${i}; \
+ done
.PHONY: ChangeLog test
@@ -88,9 +103,9 @@ ChangeLog:
LC_ALL=C svn2cl
rm -f *.bak
-test: $(pkg_gdata) $(pkg_gscripts) $(macrosfiles)
+test: $(pkg_gdata) $(pkg_gscripts) $(macrosfiles) $(pkg_gconfig)
sh tests.sh
-CLEANFILES = $(pkg_gdata) $(pkg_gscripts) $(macrosfiles) \
+CLEANFILES = $(pkg_gdata) $(pkg_gscripts) $(macrosfiles) $(pkg_gconfig)\
macros-perarch \
make_macrosfiles.sh