aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 7 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 75e0a7b..d253892 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,10 +2,12 @@
arch_macrosfiles = $(RPMALLARCH:=.macros)
-pkg_data =
+pkg_data = \
+ rpmpopt
pkg_gdata = \
- macros
+ macros \
+ rpmrc
pkg_sysconf_macros_tmp = \
build.macros
@@ -47,8 +49,6 @@ pkg_scripts = \
php.req \
pkgconfigdeps.sh \
pythoneggs.py \
- rpmb_deprecated \
- rpmpopt \
rubygems.rb
pkg_gscripts = \
@@ -88,6 +88,7 @@ EXTRA_DIST = \
macros-perarch.in make_arch_macrosfiles.sh.in \
rpmgenplatform.in rpmrc.in \
rpm-spec-mode.el \
+ rpmb_deprecated \
tests.sh tests/macros.sh \
tests/findlang.pl tests/findlang.sh
@@ -125,6 +126,7 @@ else
done
endif
[ -d $(DESTDIR)$(RPMSYSCONFDIR)/macros.d ] || $(mkinstalldirs) $(DESTDIR)$(RPMSYSCONFDIR)/macros.d
+ $(install_sh_SCRIPT) rpmb_deprecated $(DESTDIR)$(RPMLIBDIR)
for i in $(pkg_sysconf_macros); do \
$(install_sh_DATA) $${i} $(DESTDIR)$(RPMSYSCONFDIR)/macros.d/$${i}; \
done
@@ -158,5 +160,5 @@ test: $(pkg_gdata) $(pkg_gscripts) $(arch_macrosfiles) $(pkg_gconfig)
sh tests.sh
CLEANFILES = $(pkg_gdata) $(pkg_gscripts) $(arch_macrosfiles) $(pkg_gconfig)\
- rpmrc macros-perarch $(pkg_sysconf_macros_tmp) \
+ macros-perarch $(pkg_sysconf_macros_tmp) \
make_arch_macrosfiles.sh