aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 9 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index f5357f0..1ab58bf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
# $Id$
-macrosfiles = $(RPMALLARCH:=.macros)
+arch_macrosfiles = $(RPMALLARCH:=.macros)
pkg_data = \
rpmpopt
@@ -40,7 +40,7 @@ pkg_gscripts = \
pkg_scripts_in = $(pkg_gscripts:=.in)
-BUILT_SOURCES = macros-perarch make_macrosfiles.sh rpmgenplatform
+BUILT_SOURCES = macros-perarch make_arch_macrosfiles.sh rpmgenplatform
pkglibdir = @RPMVENDORDIR@
@@ -66,7 +66,7 @@ EXTRA_DIST = \
$(pkg_data_in) \
$(pkg_scripts) \
$(pkg_scripts_in) \
- macros-perarch.in make_macrosfiles.sh.in \
+ macros-perarch.in make_arch_macrosfiles.sh.in \
rpmgenplatform.in \
rpm-spec-mode.el \
rpmb_deprecated \
@@ -86,9 +86,9 @@ edit = sed \
%: %.in Makefile
$(edit) $< > $@
-%.macros: macros-perarch make_macrosfiles.sh
+%.macros: macros-perarch make_arch_macrosfiles.sh
arch=`echo $@ | sed 's,\\.macros,,'`; \
- sh ./make_macrosfiles.sh macros-perarch $$arch > $@
+ sh ./make_arch_macrosfiles.sh macros-perarch $$arch > $@
platform: rpmgenplatform Makefile
perl rpmgenplatform $(CANONTARGETCPU) > $@
@@ -96,7 +96,7 @@ platform: rpmgenplatform Makefile
platform32: rpmgenplatform Makefile
perl rpmgenplatform $(CANONTARGETCPU32) > $@
-install-data-local: $(macrosfiles) $(pkg_gconfig)
+install-data-local: $(arch_macrosfiles) $(pkg_gconfig)
if ONLY_RPMRC
echo "not installing per-arch macros which are already in rpmrc and standard rpm per-arch macros"
else
@@ -120,9 +120,9 @@ ChangeLog:
LC_ALL=C svn2cl
rm -f *.bak
-test: $(pkg_gdata) $(pkg_gscripts) $(macrosfiles) $(pkg_gconfig)
+test: $(pkg_gdata) $(pkg_gscripts) $(arch_macrosfiles) $(pkg_gconfig)
sh tests.sh
-CLEANFILES = $(pkg_gdata) $(pkg_gscripts) $(macrosfiles) $(pkg_gconfig)\
+CLEANFILES = $(pkg_gdata) $(pkg_gscripts) $(arch_macrosfiles) $(pkg_gconfig)\
macros-perarch \
- make_macrosfiles.sh
+ make_arch_macrosfiles.sh