aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c694305..f5357f0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,10 +97,14 @@ platform32: rpmgenplatform Makefile
perl rpmgenplatform $(CANONTARGETCPU32) > $@
install-data-local: $(macrosfiles) $(pkg_gconfig)
+if ONLY_RPMRC
+ echo "not installing per-arch macros which are already in rpmrc and standard rpm per-arch macros"
+else
for i in $(RPMALLARCH); do \
$(mkinstalldirs) $(DESTDIR)$(RPMVENDORDIR)/$${i}-$(RPMOS); \
$(install_sh_DATA) $${i}.macros $(DESTDIR)$(RPMVENDORDIR)/$${i}-$(RPMOS)/macros; \
done
+endif
[ -d $(DESTDIR)$(RPMSYSCONFDIR) ] || $(mkinstalldirs) $(DESTDIR)$(RPMSYSCONFDIR)
$(install_sh_SCRIPT) rpmb_deprecated $(DESTDIR)$(RPMLIBDIR)
if RPMPLATFORM