aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPascal Terjan <pterjan@gmail.com>2016-04-12 08:47:42 +0100
committerPascal Terjan <pterjan@gmail.com>2016-04-12 08:47:42 +0100
commit453e1dfae7bd7e5fa8be4bf1ef3ec68fdcffcd6f (patch)
tree141da2a1214013903245f4e7bb3bb2fca73c5111 /configure.ac
parent3609fc391a2be8729023a7e3086003c6314b7874 (diff)
downloadrpm-setup-453e1dfae7bd7e5fa8be4bf1ef3ec68fdcffcd6f.tar
rpm-setup-453e1dfae7bd7e5fa8be4bf1ef3ec68fdcffcd6f.tar.gz
rpm-setup-453e1dfae7bd7e5fa8be4bf1ef3ec68fdcffcd6f.tar.bz2
rpm-setup-453e1dfae7bd7e5fa8be4bf1ef3ec68fdcffcd6f.tar.xz
rpm-setup-453e1dfae7bd7e5fa8be4bf1ef3ec68fdcffcd6f.zip
use rtp's solution to build for armv5tl on armv5tl distro
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 69c7da5..2502a6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,7 @@ AC_CHECK_HEADERS([string.h])
CANONTARGETCPU=${target_cpu}
CANONTARGETGNU=-gnu
+ARMV7CANONTARGETCPU="armv5tl"
case "${target_cpu}" in
*86|athlon|k6|pentium*)
@@ -96,12 +97,14 @@ case "${target_cpu}" in
RPMALLARCH="armv7hl"
CANONTARGETCPU=armv7hl
CANONTARGETGNU=-gnueabi
+ ARMV7CANONTARGETCPU="armv7hl"
esac
RPMALLARCH="${RPMALLARCH} noarch"
AC_SUBST(RPMALLARCH)
AC_SUBST(CANONTARGETCPU)
AC_SUBST(CANONTARGETCPU32)
AC_SUBST(CANONTARGETGNU)
+AC_SUBST(ARMV7CANONTARGETCPU)
#
# get rid of the 4-th tuple, if config.guess returned "linux-gnu" for build_os