aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPascal Rigaux <pixel@mandriva.com>2007-12-19 18:12:54 +0000
committerPascal Rigaux <pixel@mandriva.com>2007-12-19 18:12:54 +0000
commit93ba0c64e011dca6fe6df90508bc10efc75159ec (patch)
tree6d2fd853fb9a68f4df2320ce49895e58036dfdf1 /Makefile.am
parent607e6ccbc58d54b73e5737010ba196d7e7e0c5cc (diff)
downloadrpm-setup-93ba0c64e011dca6fe6df90508bc10efc75159ec.tar
rpm-setup-93ba0c64e011dca6fe6df90508bc10efc75159ec.tar.gz
rpm-setup-93ba0c64e011dca6fe6df90508bc10efc75159ec.tar.bz2
rpm-setup-93ba0c64e011dca6fe6df90508bc10efc75159ec.tar.xz
rpm-setup-93ba0c64e011dca6fe6df90508bc10efc75159ec.zip
1.65:1.65
- add option --with-rpmplatform to install or not /etc/rpm/platform and genplatform - rpm-spec-mode.el: use buildroot macro instead of RPM_BUILD_ROOT environment variable
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4ff89e6..b4352c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,10 +101,12 @@ install-data-local: $(macrosfiles) $(pkg_gconfig)
$(install_sh_DATA) $${i}.macros $(DESTDIR)$(RPMVENDORDIR)/$${i}-$(RPMOS)/macros; \
done
[ -d $(DESTDIR)$(RPMSYSCONFDIR) ] || $(mkinstalldirs) $(DESTDIR)$(RPMSYSCONFDIR)
+if RPMPLATFORM
for i in $(pkg_gconfig); do \
$(install_sh_DATA) $${i} $(DESTDIR)$(RPMSYSCONFDIR)/$${i}; \
done
$(install_sh_SCRIPT) rpmgenplatform $(DESTDIR)$(bindir)/rpmgenplatform
+endif
.PHONY: ChangeLog test