aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 0308b27..3274db1 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -51,6 +51,10 @@ ChangeLog:
my @rpmflags;
my $ldflags = `pkg-config --libs rpm`;
+if ($hversion ge hexversion("4.9.0") && $hversion lt hexversion("5.0")) {
+ # rpm.org version 4.9.0
+ push @rpmflags, "-DRPM490";
+}
if ($hversion ge hexversion("4.4.90") && $hversion lt hexversion("5.0")) {
# rpm.org version
push @rpmflags, "-DRPM_ORG";