aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 43a2444..e321882 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -46,12 +46,17 @@ rpm: rpmdist
**MM**
}
+my $ccflags = '-Wall -fno-strict-aliasing';
+if ($version =~ /^4\.(?:[5-9]\.|\d\d)/) {
+ $ccflags .= ' -DRPM_CALLBACK_LONGLONG';
+}
+
WriteMakefile(
NAME => 'URPM',
PREREQ_PM => {
'MDV::Packdrakeng' => '1.00',
},
- CCFLAGS => '-Wall -fno-strict-aliasing',
+ CCFLAGS => $ccflags,
VERSION_FROM => 'URPM.pm',
LIBS => [ '-lrpm -lrpmio -lrpmdb -lrpmbuild -lpopt -lz' ],
INC => '-I/usr/include/rpm',