aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL8
1 files changed, 2 insertions, 6 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 3274db1..9b5b3d0 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -50,16 +50,12 @@ ChangeLog:
}
my @rpmflags;
-my $ldflags = `pkg-config --libs rpm`;
+my $ldflags = `pkg-config --libs rpm -lrpmbuild`;
if ($hversion ge hexversion("4.9.0") && $hversion lt hexversion("5.0")) {
# rpm.org version 4.9.0
push @rpmflags, "-DRPM490";
}
-if ($hversion ge hexversion("4.4.90") && $hversion lt hexversion("5.0")) {
- # rpm.org version
- push @rpmflags, "-DRPM_ORG";
- $ldflags .= ' -lrpmbuild';
-}
+
my $ccflags = join(' ', '-Wall -Wextra -fno-strict-aliasing', @rpmflags);
print "Found RPM version $version (compiling with flags: $ccflags)\n";