aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index e2dc5d4..894ca83 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -17,6 +17,8 @@ unless (defined $rpm_path) {
defined $rpm_path or die "Can't find rpm on this system\n";
my $version = `LC_ALL=C $rpm_path --version`;
+# fix compiling with RCs:
+$version =~ s/-.*//;
chomp $version;
$version =~ s/(RPM version )|(rpm \(RPM\) )//;
my $pversion = eval "v$version";