aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorThierry Vignaud <thierry.vignaud@gmail.com>2020-04-29 05:44:03 +0200
committerThierry Vignaud <thierry.vignaud@gmail.com>2020-04-29 05:55:43 +0200
commit3eff1f6b63309697d4916ab646f289be7af4a8b9 (patch)
tree64c398db12e06f9e574b02de64d33e9fb757dc7a /Makefile.PL
parent54a0ee60730839c3e461b3e81b188f22a41321cc (diff)
downloadperl-URPM-3eff1f6b63309697d4916ab646f289be7af4a8b9.tar
perl-URPM-3eff1f6b63309697d4916ab646f289be7af4a8b9.tar.gz
perl-URPM-3eff1f6b63309697d4916ab646f289be7af4a8b9.tar.bz2
perl-URPM-3eff1f6b63309697d4916ab646f289be7af4a8b9.tar.xz
perl-URPM-3eff1f6b63309697d4916ab646f289be7af4a8b9.zip
restore support for rpm-4.9
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 080003d..9f26e1e 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -4,7 +4,7 @@ use ExtUtils::PkgConfig;
# minimum required version of dependencies we need to build
our %build_reqs = (
- 'rpm' => '4.11.0',
+ 'rpm' => '4.9.0',
);
our %CONFIGURE_REQUIRES = (
'ExtUtils::Depends' => '0.300',
@@ -40,6 +40,7 @@ print $FH "/* File generated by Makefile.PL\n";
print $FH " */\n\n";
print $FH "#ifndef RPMVERSION_H\n#define RPMVERSION_H\n\n";
foreach (qw(
+ 4.10.0
4.11.0
4.12.0
4.13.0
@@ -56,6 +57,9 @@ print $FH "\n#endif\n";
close($FH);
my $workaround;
+if (-e '/etc/mageia-release' && $cfg{modversion} =~ /4\.9\./) {
+ $workaround = '-DPATCHED_MGA';
+}
if (! -e '/etc/mageia-release' && -e '/etc/redhat-release' && $cfg{modversion} =~ /4.11/) {
$workaround = '-DPATCHED_RH';
}