aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorThierry Vignaud <tv@mageia.org>2011-04-16 07:49:31 +0000
committerThierry Vignaud <tv@mageia.org>2011-04-16 07:49:31 +0000
commitf4c504acf2520f4765bcc5c2294065c72989b777 (patch)
tree376b8b320c0ca20ac9d0e9e042ab920b604039d8 /Makefile.PL
parente574fa64644a04ba211ac21a4baa9e9aa3ccc546 (diff)
downloadperl-URPM-f4c504acf2520f4765bcc5c2294065c72989b777.tar
perl-URPM-f4c504acf2520f4765bcc5c2294065c72989b777.tar.gz
perl-URPM-f4c504acf2520f4765bcc5c2294065c72989b777.tar.bz2
perl-URPM-f4c504acf2520f4765bcc5c2294065c72989b777.tar.xz
perl-URPM-f4c504acf2520f4765bcc5c2294065c72989b777.zip
clean rpm5 support out
Diffstat (limited to 'Makefile.PL')
-rwxr-xr-xMakefile.PL8
1 files changed, 2 insertions, 6 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 3274db1..9b5b3d0 100755
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -50,16 +50,12 @@ ChangeLog:
}
my @rpmflags;
-my $ldflags = `pkg-config --libs rpm`;
+my $ldflags = `pkg-config --libs rpm -lrpmbuild`;
if ($hversion ge hexversion("4.9.0") && $hversion lt hexversion("5.0")) {
# rpm.org version 4.9.0
push @rpmflags, "-DRPM490";
}
-if ($hversion ge hexversion("4.4.90") && $hversion lt hexversion("5.0")) {
- # rpm.org version
- push @rpmflags, "-DRPM_ORG";
- $ldflags .= ' -lrpmbuild';
-}
+
my $ccflags = join(' ', '-Wall -Wextra -fno-strict-aliasing', @rpmflags);
print "Found RPM version $version (compiling with flags: $ccflags)\n";