aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorRafael Garcia-Suarez <rgarciasuarez@mandriva.com>2006-06-07 09:39:33 +0000
committerRafael Garcia-Suarez <rgarciasuarez@mandriva.com>2006-06-07 09:39:33 +0000
commitdf81ef253379e556778d074cbaf323da61c1f91b (patch)
tree721c58169bb68e52dcfec3ef02e71c68357b9f3b /Makefile.PL
parente9f93aa1ade286d86c244c3b3333e4ce5f360fd6 (diff)
downloadperl-URPM-df81ef253379e556778d074cbaf323da61c1f91b.tar
perl-URPM-df81ef253379e556778d074cbaf323da61c1f91b.tar.gz
perl-URPM-df81ef253379e556778d074cbaf323da61c1f91b.tar.bz2
perl-URPM-df81ef253379e556778d074cbaf323da61c1f91b.tar.xz
perl-URPM-df81ef253379e556778d074cbaf323da61c1f91b.zip
Use svn2cl to generate ChangeLog, and regenerate it
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 8ec2248..c1e4689 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -26,12 +26,22 @@ print "Found RPM version $version\n";
my $rpmtopdir = `$rpm_path --eval '%{_topdir}'`;
chomp $rpmtopdir;
+# to generate the ChangeLog depending on the checkout layout
+my $commonusername = "../common/";
+-d $commonusername or do {
+ $commonusername = "../../common/";
+ -d $commonusername or do {
+ $commonusername = "../../../common/";
+ -d $commonusername or $commonusername = "";
+ };
+};
+
sub MY::postamble {
<<"**MM**";
.PHONY: ChangeLog rpmdist srpm rpm
ChangeLog:
- cvs2cl -W 400 -I ChangeLog --accum -U ../common/username
+ svn2cl --accum --strip-prefix=soft/rpm/perl-URPM/trunk --authors ${commonusername}username.xml
rm -f *.bak
rpmdist: dist