aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorPer Øyvind Karlsen <peroyvind@mandriva.org>2008-02-27 21:45:15 +0000
committerPer Øyvind Karlsen <peroyvind@mandriva.org>2008-02-27 21:45:15 +0000
commit95ccfb112016c55b159e351fb0d732ea54ce638f (patch)
treedf67a938e0e8bd39e7d928382cab49a4b0945290 /Makefile.PL
parent99b601773eced928c675253cb2e1c0d96a34c1cc (diff)
downloadperl-URPM-95ccfb112016c55b159e351fb0d732ea54ce638f.tar
perl-URPM-95ccfb112016c55b159e351fb0d732ea54ce638f.tar.gz
perl-URPM-95ccfb112016c55b159e351fb0d732ea54ce638f.tar.bz2
perl-URPM-95ccfb112016c55b159e351fb0d732ea54ce638f.tar.xz
perl-URPM-95ccfb112016c55b159e351fb0d732ea54ce638f.zip
fix building with rpm5 DEVEL version
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 894ca83..bb14a86 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -18,7 +18,7 @@ defined $rpm_path or die "Can't find rpm on this system\n";
my $version = `LC_ALL=C $rpm_path --version`;
# fix compiling with RCs:
-$version =~ s/-.*//;
+$version =~ s/(-.*)|(\.DEVEL)//;
chomp $version;
$version =~ s/(RPM version )|(rpm \(RPM\) )//;
my $pversion = eval "v$version";
@@ -62,7 +62,7 @@ if ($pversion ge v4.4.90 && $pversion lt v4.5) {
if ($pversion ge v4.5) {
push @rpmflags, '-DRPM_450';
}
- if ($pversion ge v5.0.0) {
+ if ($pversion ge v5.0) {
push @rpmflags, '-DRPM_500 -DWITH_DB';
}
}