aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorPascal Rigaux <pixel@mandriva.com>2007-01-15 07:40:56 +0000
committerPascal Rigaux <pixel@mandriva.com>2007-01-15 07:40:56 +0000
commit826fec5b963322a4f9ac7e32054e415ed426cbde (patch)
tree46b9d88161057a2fc9109d5f61bb1f7491fd38fc /Makefile.PL
parentb613e2c025c9730464d7f552c5ec5cabff5fcef6 (diff)
downloadperl-URPM-826fec5b963322a4f9ac7e32054e415ed426cbde.tar
perl-URPM-826fec5b963322a4f9ac7e32054e415ed426cbde.tar.gz
perl-URPM-826fec5b963322a4f9ac7e32054e415ed426cbde.tar.bz2
perl-URPM-826fec5b963322a4f9ac7e32054e415ed426cbde.tar.xz
perl-URPM-826fec5b963322a4f9ac7e32054e415ed426cbde.zip
perl-URPM.spec is no more bundled with dist, removing "rpm" and "srpm" targets
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL16
1 files changed, 1 insertions, 15 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 454b147..018dc32 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -23,10 +23,6 @@ $version =~ /^(?:4\.[2-9]|[5-9]|\d{2})/
or die "Unable to build URPM with too old (or undetected) rpm version $version\n";
print "Found RPM version $version\n";
-# directory where to build an rpm of this
-my $rpmtopdir = `$rpm_path --eval '%{_topdir}'`;
-chomp $rpmtopdir;
-
# to generate the ChangeLog depending on the checkout layout
my $commonusername = "../common/";
-d $commonusername or do {
@@ -39,21 +35,11 @@ my $commonusername = "../common/";
sub MY::postamble {
<<"**MM**";
-.PHONY: ChangeLog rpmdist srpm rpm
+.PHONY: ChangeLog
ChangeLog:
LC_ALL=C svn2cl --accum --strip-prefix=soft/rpm/perl-URPM/trunk --authors ${commonusername}username.xml
rm -f *.bak
-
-rpmdist: dist
- cp -f perl-URPM.spec $rpmtopdir/SPECS
- mv -f URPM-*.tar.bz2 $rpmtopdir/SOURCES
-
-srpm: rpmdist
- rpmbuild -bs --clean --rmsource $rpmtopdir/SPECS/perl-URPM.spec
-
-rpm: rpmdist
- rpmbuild -ba --clean --rmsource $rpmtopdir/SPECS/perl-URPM.spec
**MM**
}