aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorThierry Vignaud <tv@mandriva.org>2008-02-08 16:55:37 +0000
committerThierry Vignaud <tv@mandriva.org>2008-02-08 16:55:37 +0000
commitd6553e80c9c2c71549f46433eb1073dd5627f93c (patch)
tree60f1c90cabdd4d30b8fb2fb61a5c30003a2d30cf /Makefile.PL
parentf94a46824db57b95fa838e07fc732b59a31da5c6 (diff)
downloadperl-URPM-d6553e80c9c2c71549f46433eb1073dd5627f93c.tar
perl-URPM-d6553e80c9c2c71549f46433eb1073dd5627f93c.tar.gz
perl-URPM-d6553e80c9c2c71549f46433eb1073dd5627f93c.tar.bz2
perl-URPM-d6553e80c9c2c71549f46433eb1073dd5627f93c.tar.xz
perl-URPM-d6553e80c9c2c71549f46433eb1073dd5627f93c.zip
fix compiling with RCs
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
index e2dc5d4..894ca83 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -17,6 +17,8 @@ unless (defined $rpm_path) {
defined $rpm_path or die "Can't find rpm on this system\n";
my $version = `LC_ALL=C $rpm_path --version`;
+# fix compiling with RCs:
+$version =~ s/-.*//;
chomp $version;
$version =~ s/(RPM version )|(rpm \(RPM\) )//;
my $pversion = eval "v$version";