summaryrefslogtreecommitdiffstats
path: root/Makefile.PL
diff options
context:
space:
mode:
authorPascal Rigaux <pixel@mandriva.com>2005-11-25 16:01:32 +0000
committerPascal Rigaux <pixel@mandriva.com>2005-11-25 16:01:32 +0000
commita453b3e5b567506bc517b6a3b32a71d05937eaaa (patch)
tree3dca778f679c889ef6c30a9390ffaaefa11a118e /Makefile.PL
parent2d0f2531bb08e338e8679c0f2afd067c31368cd8 (diff)
downloadperl-MDK-Common-a453b3e5b567506bc517b6a3b32a71d05937eaaa.tar
perl-MDK-Common-a453b3e5b567506bc517b6a3b32a71d05937eaaa.tar.gz
perl-MDK-Common-a453b3e5b567506bc517b6a3b32a71d05937eaaa.tar.bz2
perl-MDK-Common-a453b3e5b567506bc517b6a3b32a71d05937eaaa.tar.xz
perl-MDK-Common-a453b3e5b567506bc517b6a3b32a71d05937eaaa.zip
perl-MDK-Common-devel replaced by package perl_checker
=> perl-MDK-Common is a simple perl package, no more requiring ocaml
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..5e3beaf
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,17 @@
+use ExtUtils::MakeMaker;
+
+if ($ENV{MAKEFILE_NAME}) {
+ symlink '.', 'lib';
+ system("perl lib/MDK/Common.pm.pl > lib/MDK/Common.pm");
+}
+
+WriteMakefile(
+ NAME => 'MDK::Common',
+ VERSION_FROM => 'lib/MDK/Common.pm',
+ ABSTRACT_FROM => 'lib/MDK/Common.pm',
+ AUTHOR => 'Pixel <pixel@mandriva.com>',
+ $ENV{MAKEFILE_NAME} ? (
+ MAKEFILE => $ENV{MAKEFILE_NAME},
+ dist => { COMPRESS => "bzip2 -f" },
+ ) : (),
+);