aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEugeni Dodonov <eugeni@mandriva.com>2009-09-29 13:49:39 -0300
committerEugeni Dodonov <eugeni@mandriva.com>2009-09-29 13:49:39 -0300
commit4a0fe20560e5a414af7329354efcd5b76007a240 (patch)
tree173fe123275ea8c3d5fcb6301c5c47119e479d77 /setup.py
parent2225dc2676f6e1c04d34feebf604b41a8e9ec331 (diff)
downloadnet_monitor-4a0fe20560e5a414af7329354efcd5b76007a240.tar
net_monitor-4a0fe20560e5a414af7329354efcd5b76007a240.tar.gz
net_monitor-4a0fe20560e5a414af7329354efcd5b76007a240.tar.bz2
net_monitor-4a0fe20560e5a414af7329354efcd5b76007a240.tar.xz
net_monitor-4a0fe20560e5a414af7329354efcd5b76007a240.zip
now building and installing everything from setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..3d2af8c
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,23 @@
+from version import *
+
+from distutils.core import setup, Extension
+
+module1 = Extension('net_monitor',
+ sources=['native/net_monitor.c'])
+
+setup (name='net_monitor',
+ version=version,
+ description='Mandriva network monitoring tool',
+ author="Eugeni Dodonov",
+ author_email="eugeni@mandriva.com",
+ url="http://www.mandriva.com",
+ license="GPL",
+ long_description=
+"""\
+This is a network monitoring tool for Mandriva Linux, intended to replace the
+old net_monitor from drakx-net. It supports graphical network monitoring and
+some advanced features, such as network profiling, activity monitoring,
+detailed logging and network traffic statistics with help of vnstat reporting.
+""",
+ scripts=["net_monitor"],
+ ext_modules=[module1])